summaryrefslogtreecommitdiffstats
path: root/main/freeswitch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-05-20 12:40:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-05-20 12:41:28 +0000
commit80734b62bb8c2c91f0f0c231f7124647b0481e54 (patch)
tree1117f7dedf62cfe62466713c23edb4bfee936b7c /main/freeswitch
parentb4c069d9e89be7815b2a621b8c1f5bc26e6bb22a (diff)
downloadaports-80734b62bb8c2c91f0f0c231f7124647b0481e54.tar.bz2
aports-80734b62bb8c2c91f0f0c231f7124647b0481e54.tar.xz
main/freeswitch: fix init.d script
and build fix for portaudio and ccache ref #1172
Diffstat (limited to 'main/freeswitch')
-rw-r--r--main/freeswitch/APKBUILD5
-rwxr-xr-xmain/freeswitch/freeswitch.initd2
2 files changed, 4 insertions, 3 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 29080dd48..2d4718934 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -4,7 +4,7 @@ pkgname=freeswitch
_snapshot=20120312
pkgver=1.0.7_p${_snapshot}
_commit=5e4a514531de2a1d8040c3d306a9e8de426de566
-pkgrel=4
+pkgrel=5
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
arch="all"
@@ -86,6 +86,7 @@ build() {
# first build libfreeswitch (in parallel)
make src/include/switch_version.h src/include/switch_swigable_cpp.h
+ (cd libs/portaudio && make SHELL=/bin/bash) || return 1
make libfreeswitch.la || return 1
# finally we build the rest
make -j1 all || return 1
@@ -177,4 +178,4 @@ md5sums="8c0609c00039513a1a81eda685845b37 freeswitch-5e4a514531de2a1d8040c3d306
769eaa127d4dbae687dc4aa961a8cc70 0002-mod_lua-alpine-module-search-path.patch
1e6f8a9f18c9c332872cdc40065b76e3 modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
-06d70089ce96abc47a01bf69511a978a freeswitch.initd"
+54a929d16731df730de0cd5355ea3031 freeswitch.initd"
diff --git a/main/freeswitch/freeswitch.initd b/main/freeswitch/freeswitch.initd
index ee07de537..afeeb886a 100755
--- a/main/freeswitch/freeswitch.initd
+++ b/main/freeswitch/freeswitch.initd
@@ -23,7 +23,7 @@ start() {
OPTS="${OPTS} ${FREESWITCH_OPTS}"
checkpath -q -d \
- -o ${FREESWITCH_USER:freeswitch}:${FREESWITCH_GROUP:-freeswitch}\
+ -o ${FREESWITCH_USER:-freeswitch}:${FREESWITCH_GROUP:-freeswitch}\
-m 0770 /var/run/freeswitch
ebegin "Starting Freeswitch"
limits