summaryrefslogtreecommitdiffstats
path: root/main/freeswitch
diff options
context:
space:
mode:
authorCameron Banta <cbanta@gmail.com>2011-05-28 01:56:41 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-06-01 10:56:13 +0000
commit9e0dd43b37174f24d8f1072760161b16a359d563 (patch)
treee0c7190b11c7d74bc1df7c3173527b7504a790ec /main/freeswitch
parent6117e45c4fd17bcb54592ccda0e223697e71005a (diff)
downloadaports-9e0dd43b37174f24d8f1072760161b16a359d563.tar.bz2
aports-9e0dd43b37174f24d8f1072760161b16a359d563.tar.xz
main/freeswitch: update to latest version
Diffstat (limited to 'main/freeswitch')
-rw-r--r--main/freeswitch/APKBUILD37
-rw-r--r--main/freeswitch/modules.conf72
2 files changed, 85 insertions, 24 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index b07f3c97c..9225b053e 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -1,19 +1,21 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=freeswitch
-pkgver=1.0.7_p20110323
+pkgver=1.0.7_p20110527
_ver=${pkgver%_p*}
_snapshot=${pkgver#*_p}
-pkgrel=1
+pkgrel=0
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
arch="all"
license="GPL"
depends=""
makedepends="curl-dev unixodbc-dev zlib-dev openssl-dev ncurses-dev
- autoconf automake libtool libpri-dev bash"
+ autoconf automake libtool libpri-dev bash net-snmp-dev postgresql-dev
+ libiconv-dev subversion flac-dev libogg-dev libvorbis-dev
+ jpeg-dev"
install="$pkgname.pre-install $pkgname.post-install $pkgname.pre-upgrade"
-subpackages="$pkgname-dev $pkgname-flite $pkgname-sample-config:conf"
+subpackages="$pkgname-dev $pkgname-flite $pkgname-sample-config:conf $pkgname-freetdm"
source="saveas-http://latest.freeswitch.org/freeswitch-$_ver.tar.gz/freeswitch-$pkgver.tar.gz
freeswitch-mod_shout-textrels.patch
modules.conf
@@ -40,7 +42,7 @@ build() {
# by specifying it here we save our selves from some CPU cycles
export lt_cv_sys_max_cmd_len=8192
- ./rebootstrap.sh
+ ./bootstrap.sh
cp -f "$srcdir/modules.conf" modules.conf || return 1
@@ -93,15 +95,28 @@ _mv_mod() {
flite() {
pkgdesc="Freeswitch Text To Speech Module"
- depends="freeswitch"
install=
- _mv_mod mod_flite mod_say_de mod_say_en mod_say_es mod_say_fr \
- mod_say_it mod_say_nl mod_say_zh
+ _mv_mod mod_flite
+##
+## The mod_say_xx modules can be used with out flite (for numbers, etc using
+## sound files). So they shouldn't be in the flite package -cB
+##
+# _mv_mod mod_say_de mod_say_en mod_say_es mod_say_fr \
+# mod_say_it mod_say_nl mod_say_zh mod_say_hu mod_say_ru \
+# mod_say_th mod_say_he
+}
+
+freetdm() {
+ pkgdesc="Freeswitch FreeTDM Module"
+ install=
+ _mv_mod mod_freetdm ftmod_analog ftmod_analog_em ftmod_libpri \
+ ftmod_skel ftmod_zt
+ mv "$pkgdir"/usr/lib/libfreetdm.so* "$subpkgdir"/usr/lib/
}
conf() {
pkgdesc="Freeswitch sample configureation"
- depends="freeswitch"
+ arch="noarch"
install=
mkdir -p "$subpkgdir"/etc/freeswitch
# move all configs except freeswitch.xml
@@ -112,8 +127,8 @@ conf() {
mkdir -p "$pkgdir"/etc/freeswitch/scripts
}
-md5sums="ecca23d810c8ec1853c87c7fdc603bc5 freeswitch-1.0.7_p20110323.tar.gz
+md5sums="da85600034285da3d96c864201c4e08b freeswitch-1.0.7_p20110527.tar.gz
11883affe0839a8e15fe680aeb11b86e freeswitch-mod_shout-textrels.patch
-8363688bc8dd21ac1da0f840d770504b modules.conf
+691fa3aca967203848bbb2a617545265 modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
aa358c9ca0d8b93fabb6a36a5ed4c469 freeswitch.initd"
diff --git a/main/freeswitch/modules.conf b/main/freeswitch/modules.conf
index beb351f19..b87e6786c 100644
--- a/main/freeswitch/modules.conf
+++ b/main/freeswitch/modules.conf
@@ -1,70 +1,107 @@
loggers/mod_console
loggers/mod_logfile
loggers/mod_syslog
+#applications/mod_cidlookup
applications/mod_commands
applications/mod_conference
applications/mod_dptools
applications/mod_enum
+#applications/mod_osp
applications/mod_fifo
-#applications/mod_fax
+applications/mod_curl
+applications/mod_db
+applications/mod_hash
+#applications/mod_redis
applications/mod_voicemail
+applications/mod_directory
#applications/mod_lcr
-applications/mod_limit
applications/mod_expr
applications/mod_esf
#applications/mod_easyroute
applications/mod_fsv
+#applications/mod_nibblebill
#applications/mod_soundtouch
#applications/mod_rss
+applications/mod_spandsp
#applications/mod_snom
#applications/mod_vmd
-asr_tts/mod_flite
-#asr_tts/mod_pocketsphinx
-#asr_tts/mod_cepstral
+#applications/mod_avmd
+#applications/mod_memcache
+#applications/mod_spy
+applications/mod_cluechoo
+applications/mod_valet_parking
+applications/mod_distributor
+#applications/mod_stress
+#applications/mod_snapshot
+#applications/mod_snipe_hunt
+applications/mod_callcenter
+#applications/mod_fsk
+#applications/mod_ladspa
+#applications/mod_mongo
codecs/mod_g723_1
codecs/mod_amr
#codecs/mod_amrwb
+#codecs/mod_silk
+#codecs/mod_codec2
codecs/mod_g729
+#codecs/mod_com_g729
codecs/mod_h26x
-codecs/mod_voipcodecs
+codecs/mod_bv
codecs/mod_ilbc
codecs/mod_speex
-#codecs/mod_siren
+codecs/mod_siren
#codecs/mod_celt
+#codecs/mod_opus
+#codecs/mod_sangoma_codec
#codecs/mod_dahdi_codec
#dialplans/mod_dialplan_directory
dialplans/mod_dialplan_xml
dialplans/mod_dialplan_asterisk
#directories/mod_ldap
#endpoints/mod_dingaling
-endpoints/mod_iax
#endpoints/mod_portaudio
endpoints/mod_sofia
endpoints/mod_loopback
#endpoints/mod_alsa
#endpoints/mod_opal
+#endpoints/mod_skinny
+#endpoints/mod_skypopen
+#endpoints/mod_h323
+#endpoints/mod_khomp
+#endpoints/mod_gsmopen
+#../../libs/openzap/mod_openzap
../../libs/freetdm/mod_freetdm
+#asr_tts/mod_unimrcp
+asr_tts/mod_flite
+#asr_tts/mod_pocketsphinx
+#asr_tts/mod_cepstral
+#asr_tts/mod_tts_commandline
#event_handlers/mod_event_multicast
event_handlers/mod_event_socket
+#event_handlers/mod_event_zmq
event_handlers/mod_cdr_csv
+event_handlers/mod_cdr_sqlite
+event_handlers/mod_cdr_pg_csv
#event_handlers/mod_radius_cdr
+#event_handlers/mod_erlang_event
+event_handlers/mod_snmp
formats/mod_native_file
formats/mod_sndfile
formats/mod_shout
formats/mod_local_stream
formats/mod_tone_stream
+#formats/mod_portaudio_stream
+#formats/mod_shell_stream
#languages/mod_python
#languages/mod_spidermonkey
-#languages/mod_spidermonkey_teletone
-#languages/mod_spidermonkey_core_db
-#languages/mod_spidermonkey_socket
-#languages/mod_spidermonkey_odbc
languages/mod_lua
#languages/mod_perl
#languages/mod_yaml
+#languages/mod_java
+#languages/mod_managed
xml_int/mod_xml_rpc
xml_int/mod_xml_curl
-#xml_int/mod_xml_cdr
+xml_int/mod_xml_cdr
#xml_int/mod_xml_ldap
say/mod_say_en
say/mod_say_de
@@ -72,5 +109,14 @@ say/mod_say_es
say/mod_say_fr
say/mod_say_it
say/mod_say_nl
+say/mod_say_pt
+say/mod_say_ru
say/mod_say_zh
+say/mod_say_hu
+say/mod_say_th
+say/mod_say_he
timers/mod_timerfd
+
+## Experimental Modules (don't cry if they're broken)
+#../../contrib/mod/xml_int/mod_xml_odbc
+