summaryrefslogtreecommitdiffstats
path: root/main/freeswitch
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2011-01-31 22:47:30 +0000
committerJeff Bilyk <jbilyk@gmail.com>2011-01-31 22:47:30 +0000
commitb93f7262803d7169a8a9a9a9ba583d67493aaf37 (patch)
tree678f136b9dfa0a4b464f078ccf426724f92720a0 /main/freeswitch
parente774afe3adc01be2ff08b56f06639de0cbe41f28 (diff)
downloadaports-b93f7262803d7169a8a9a9a9ba583d67493aaf37.tar.bz2
aports-b93f7262803d7169a8a9a9a9ba583d67493aaf37.tar.xz
main/freeswitch: add rebootstrap.sh call to actually fix libpri
ref #514
Diffstat (limited to 'main/freeswitch')
-rw-r--r--main/freeswitch/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index d435f7ef5..dd540f8c2 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -27,15 +27,17 @@ prepare() {
build() {
cd "$_builddir"
- cp -f "$srcdir/modules.conf" modules.conf || return 1
# i think our max cmd len is 32768
# by specifying it here we save our selves from some CPU cycles
export lt_cv_sys_max_cmd_len=8192
+ ./rebootstrap.sh
+
+ cp -f "$srcdir/modules.conf" modules.conf || return 1
+
# remove -Werror since gcc-4.5 is more strict
sed -i -e 's/-Werror//g' configure || return 1
-
./configure --prefix=/usr \
--sysconfdir=/etc/freeswitch \
--with-modinstdir=/usr/lib/freeswitch \