summaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-05-15 09:11:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-05-15 09:11:54 +0000
commit1609a4f801c6b7388a082fc592ca8322685417b3 (patch)
treeb23cec66a0f3fc58fc6982701bbd49f928c5a907 /main/gcc
parentaca3dcc0eacc3d339926c6506dc93aa43957a71e (diff)
downloadaports-1609a4f801c6b7388a082fc592ca8322685417b3.tar.bz2
aports-1609a4f801c6b7388a082fc592ca8322685417b3.tar.xz
main/gcc: ship libiberty with gcc
gcc is the upstream for libiberty https://gcc.gnu.org/ml/gcc/2013-03/msg00301.html apparently binutils no longer ship it either.
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 842986a24..80b35827b 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -9,7 +9,7 @@ _cross=""
&& _cross="-$CTARGET"
pkgname="$pkgname$_cross"
-pkgrel=9
+pkgrel=10
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -21,7 +21,7 @@ makedepends_host="gmp-dev mpfr-dev mpc1-dev zlib-dev cloog-dev !libiconv-dev !ge
makedepends="$makedepends_build $makedepends_host"
subpackages=" "
[ "$CHOST" = "$CTARGET" ] && subpackages="gcc-doc$_cross"
-replaces="libstdc++"
+replaces="libstdc++ binutils"
: ${LANG_CXX:=true}
: ${LANG_OBJC:=true}
@@ -370,9 +370,6 @@ package() {
ln -s gcc "$pkgdir"/usr/bin/cc
- # binutils provides libiberty.a
- rm -f "$pkgdir"/usr/lib/libiberty.a
-
# install the specs
local i
for i in $source; do