summaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-04-22 11:25:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-04-22 11:25:48 +0000
commita198a62b0d0e84d9708e5632ee9c2d1fa86f7a70 (patch)
treea3ca29777b7e8736ced31cb96dd980ab1297d613 /main/gcc
parent6e18ce558b763f3df6422c7180f2a6845a884a03 (diff)
downloadaports-a198a62b0d0e84d9708e5632ee9c2d1fa86f7a70.tar.bz2
aports-a198a62b0d0e84d9708e5632ee9c2d1fa86f7a70.tar.xz
main/gcc: depend on libgomp
we don't bother create a separate libgomp-dev subpackage. just depend on libgomp to make it simple we also depend on the exact gcc version when we pullin gcc pkg.
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 4f96e7f19..ed8419b76 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -7,12 +7,13 @@ _specs_gcc_ver=4.4.3
_uclibc_abiver=0.9.32
-pkgrel=0
+_gccrel=$pkgver-r$pkgrel
+pkgrel=1
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
license="GPL LGPL"
-depends="binutils"
+depends="binutils libgomp=$_gccrel"
makedepends="bison flex gmp-dev mpfr-dev texinfo mpc1-dev gawk zlib-dev zip
cloog-dev"
subpackages="$pkgname-doc libstdc++:libcxx g++:gpp libgcc libgomp"
@@ -285,7 +286,7 @@ libobjc() {
objc() {
pkgdesc="GNU Objective-C"
replaces="gcc"
- depends="libc-dev gcc"
+ depends="libc-dev gcc=$_gccrel"
local gcclibdir=usr/lib/gcc/${CHOST:-$_chost}/$pkgver
mkdir -p "$subpkgdir"/$gcclibdir/include \
"$subpkgdir"/$gcclibdir/plugin/include \
@@ -319,7 +320,7 @@ libgomp() {
java() {
pkgdesc="Java support for GCC"
- depends="zlib-dev"
+ depends="zlib-dev gcc=$_gccrel"
paxctl -c -pm "$pkgdir"/usr/libexec/gcc/*/*/ecj1 || return 1
mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/lib
cd "$pkgdir"/usr/bin
@@ -381,7 +382,7 @@ libgo() {
go() {
pkgdesc="Go support for GCC"
- depends="gcc"
+ depends="gcc=$_gccrel"
local libexec=usr/libexec/gcc/${CHOST:-$_chost}/$pkgver
mkdir -p "$subpkgdir"/$libexec \
"$subpkgdir"/usr/lib \