summaryrefslogtreecommitdiffstats
path: root/main/haserl/0001-Modernize-configure.ac-for-newer-autotools.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-07-02 16:31:41 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2013-07-02 16:32:28 +0200
commit2ef211efeb1de2e48862d6ecc2fc2bab3a702b22 (patch)
tree507e09e6f3db14eeb75c905a1b312aaf7a51103d /main/haserl/0001-Modernize-configure.ac-for-newer-autotools.patch
parentf10bce070b3bea6cfad50c28c94561df9d7c271a (diff)
downloadaports-2ef211efeb1de2e48862d6ecc2fc2bab3a702b22.tar.bz2
aports-2ef211efeb1de2e48862d6ecc2fc2bab3a702b22.tar.xz
main/haserl: upgrade to 0.9.30
Diffstat (limited to 'main/haserl/0001-Modernize-configure.ac-for-newer-autotools.patch')
-rw-r--r--main/haserl/0001-Modernize-configure.ac-for-newer-autotools.patch82
1 files changed, 82 insertions, 0 deletions
diff --git a/main/haserl/0001-Modernize-configure.ac-for-newer-autotools.patch b/main/haserl/0001-Modernize-configure.ac-for-newer-autotools.patch
new file mode 100644
index 000000000..87813fbe2
--- /dev/null
+++ b/main/haserl/0001-Modernize-configure.ac-for-newer-autotools.patch
@@ -0,0 +1,82 @@
+From 4875e8266e134d73128fd6e393429e5d24f8e4ee Mon Sep 17 00:00:00 2001
+From: Nathan Angelacos <nangel@alpinelinux.org>
+Date: Sun, 30 Jun 2013 21:58:00 -0700
+Subject: [PATCH 1/4] Modernize configure.ac for newer autotools
+
+---
+ ChangeLog | 3 +++
+ configure.ac | 14 +++++++-------
+ 2 files changed, 10 insertions(+), 7 deletions(-)
+
+diff --git a/ChangeLog b/ChangeLog
+index a244edf..dffc9d1 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,6 @@
++ 0.9.31
++ * Modernize configure.ac
++
+ 2013-27-06
+ 0.9.30
+ * The Mayhem Team of CMU found an undisclosed segfault when the first
+diff --git a/configure.ac b/configure.ac
+index 7998afb..74560c5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,6 +1,6 @@
+ # Process this file with autoconf to produce a configure script.
+-AC_INIT([haserl],[0.9.30],[Nathan Angelacos - nangel@users.sourceforge.net],[haserl])
+-AM_INIT_AUTOMAKE([haserl],[$PACKAGE_VERSION])
++AC_INIT([haserl],[0.9.31],[Nathan Angelacos - nangel@users.sourceforge.net],[haserl])
++AM_INIT_AUTOMAKE
+
+ # Checks for programs.
+ AC_PROG_CC
+@@ -56,7 +56,7 @@ ac_report_bash_extensions=disabled
+
+
+ AC_ARG_WITH(lua,
+- AC_HELP_STRING([--with-lua[[=DIR]]], [use lua in DIR]),
++ AS_HELP_STRING([--with-lua[[=DIR]]],[use lua in DIR]),
+ [ case "$withval" in
+ no) ac_report_have_lua=disabled
+ ;;
+@@ -90,7 +90,7 @@ AM_CONDITIONAL(USE_LUA, test x$ac_report_have_lua = xenabled)
+
+ # shell: ordinary Haserl code with embedded Lua
+ AC_ARG_ENABLE(luashell,
+- AC_HELP_STRING([--enable-luashell], [Includes the standard Lua shell - Haserl with embedded Lua (default is yes if Lua's enabled)]),
++ AS_HELP_STRING([--enable-luashell],[Includes the standard Lua shell - Haserl with embedded Lua (default is yes if Lua's enabled)]),
+ [case "${enableval}" in
+ yes) luashell=true ;;
+ no) luashell=false ;;
+@@ -103,7 +103,7 @@ fi
+
+ # shell: precompiled Haserl code - compiled Lua code
+ AC_ARG_ENABLE(luacshell,
+- AC_HELP_STRING([--enable-luacshell], [Includes the compiled Lua shell - precompiled Haserl/Lua (default is yes if Lua's enabled)]),
++ AS_HELP_STRING([--enable-luacshell],[Includes the compiled Lua shell - precompiled Haserl/Lua (default is yes if Lua's enabled)]),
+ [case "${enableval}" in
+ yes) luacshell=true ;;
+ no) luacshell=false ;;
+@@ -121,7 +121,7 @@ fi
+ # the Linux shell is always available
+
+ AC_ARG_ENABLE(bashshell,
+- AC_HELP_STRING([--enable-bashshell], [Includes the Bash or another Linux shell (default is yes)]),
++ AS_HELP_STRING([--enable-bashshell],[Includes the Bash or another Linux shell (default is yes)]),
+ [case "${enableval}" in
+ yes) bashshell=true ;;
+ no) bashshell=false ;;
+@@ -149,7 +149,7 @@ fi
+
+ # Do we include scott's bash extensions
+ AC_ARG_ENABLE(bash-extensions,
+- AC_HELP_STRING([--enable-bash-extensions], [Includes bash extensions to the haserl script language (default is no)]),
++ AS_HELP_STRING([--enable-bash-extensions],[Includes bash extensions to the haserl script language (default is no)]),
+ [case "${enableval}" in
+ yes) bashextensions=true
+ ac_report_bash_extensions=enabled
+--
+1.8.3.2
+