summaryrefslogtreecommitdiffstats
path: root/main/liblockfile
diff options
context:
space:
mode:
authorDuane Hughes <duanejevon@gmail.com>2011-03-22 08:30:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-22 21:03:30 +0000
commit019aab029adea34f90f2811556b8df162c3e7b46 (patch)
treeae83fe79babb2df7f6a7d658afe1fde6bbd5ef67 /main/liblockfile
parentacdd8885dd810ddcea0f0dc77b9cb34e66c97709 (diff)
downloadaports-019aab029adea34f90f2811556b8df162c3e7b46.tar.bz2
aports-019aab029adea34f90f2811556b8df162c3e7b46.tar.xz
main/{liblockfile|logcheck|lockfile-progs}: moving to main branch
verified operation, moving to main repo
Diffstat (limited to 'main/liblockfile')
-rw-r--r--main/liblockfile/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/main/liblockfile/APKBUILD b/main/liblockfile/APKBUILD
new file mode 100644
index 000000000..6f471cb11
--- /dev/null
+++ b/main/liblockfile/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Duane Hughes <duanejevon@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=liblockfile
+pkgver=1.08
+pkgrel=0
+pkgdesc="Shared library with NFS-safe locking functions"
+url="http://packages.debian.org/sid/liblockfile1"
+arch="all"
+license="GPL"
+depends=""
+makedepends=
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.debian.org/debian/pool/main/libl/liblockfile/${pkgname}_$pkgver.orig.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make -j1 || return 1
+}
+
+package() {
+ cd "$_builddir"
+
+ install -d "$pkgdir"/usr/include
+ install -d "$pkgdir"/usr/bin
+ install -d "$pkgdir"/usr/lib
+ install -d "$pkgdir"/usr/share/man
+
+ make -j1 ROOT="$pkgdir" install
+}
+
+md5sums="c24e2dfb4a2aab0263fe5ac1564d305e liblockfile_1.08.orig.tar.gz"