summaryrefslogtreecommitdiffstats
path: root/main/libtheora
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-04 08:14:13 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-10-04 08:14:13 +0000
commit0771f8daf77be294e480ba9687f2211d0f660dc8 (patch)
treeef1ddf3df6065b86fbf9812c2559598f2ddcff86 /main/libtheora
parent86d4a843ba815e4d890949b34a6e1a7a40279b17 (diff)
downloadaports-0771f8daf77be294e480ba9687f2211d0f660dc8.tar.bz2
aports-0771f8daf77be294e480ba9687f2211d0f660dc8.tar.xz
main/libtheora: fix musl build
Diffstat (limited to 'main/libtheora')
-rw-r--r--main/libtheora/APKBUILD14
-rw-r--r--main/libtheora/fix-timeb.patch75
2 files changed, 88 insertions, 1 deletions
diff --git a/main/libtheora/APKBUILD b/main/libtheora/APKBUILD
index e0ef090b0..4ebcc722d 100644
--- a/main/libtheora/APKBUILD
+++ b/main/libtheora/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtheora
pkgver=1.1.1
-pkgrel=8
+pkgrel=9
pkgdesc="An open video codec developed by the Xiph.org"
url="http://www.xiph.org"
arch="all"
@@ -12,6 +12,7 @@ makedepends="libvorbis-dev libogg-dev sdl-dev autoconf automake libtool"
source="http://downloads.xiph.org/releases/theora/$pkgname-$pkgver.tar.bz2
libtheora-flags.patch
enc.patch
+ fix-timeb.patch
automake.patch
"
@@ -65,4 +66,15 @@ examples() {
md5sums="292ab65cedd5021d6b7ddd117e07cd8e libtheora-1.1.1.tar.bz2
7cbab1ce1f52adb98e1c241515a27aca libtheora-flags.patch
5024b6c41351433bf0e8a354969f8efd enc.patch
+b82250b0a1120e73bf225a0d313b848a fix-timeb.patch
0ed0917a6dac6a0e3242b1f7ce9785a5 automake.patch"
+sha256sums="b6ae1ee2fa3d42ac489287d3ec34c5885730b1296f0801ae577a35193d3affbc libtheora-1.1.1.tar.bz2
+7efb7aec3e472914ffc0facbdc9769e088e5d69e285254d19f353555ca90c7d6 libtheora-flags.patch
+eb8452cc4022e8a591c5b1e679c8c1434d965d842411feeb7121255aae5e4cc5 enc.patch
+38228518e7a4ef0efc29cef9f99e98cce1f9668eff6e43ac783478163c08e420 fix-timeb.patch
+9a58f7cb9069c5b1792af07ddd7e5dfcc5765fd047f3dbe8e6ab9e39235da37c automake.patch"
+sha512sums="9ab9b3af1c35d16a7d6d84f61f59ef3180132e30c27bdd7c0fa2683e0d00e2c791accbc7fd2c90718cc947d8bd10ee4a5940fb55f90f1fd7b0ed30583a47dbbd libtheora-1.1.1.tar.bz2
+72916c4ed0f9609b84af7c72b35b558ecfb2ed7533739e170ed088e06d0e82a585dcc1185f3c5a5d0644d30901459813b635df2ba951e2290bcd4303cfebc20b libtheora-flags.patch
+569132fd0a576abb26b3c28fe84c4c2c66ff871129f00bfb23e593b8f985e47d61bc910d383aa3fc7477cc9de21e86f8df412901c609a62da972410733ec41f2 enc.patch
+985dd5f5f3afcb36d71a636082c6e09ec18bb9e442b552babc4706299f502b90e79fb4aacb50a43c5e87a0b8429b311bcfeb21027f6cdca6fdb81e76b491dfff fix-timeb.patch
+d72648de058d42ed85d9870596d8c42148f9bcf5b08e2a333c279e1516f4bfa6535566cda807abb06ae58bfb1e373909148cb5c10aad6f56879d9c8452f2cc4f automake.patch"
diff --git a/main/libtheora/fix-timeb.patch b/main/libtheora/fix-timeb.patch
new file mode 100644
index 000000000..5344c0757
--- /dev/null
+++ b/main/libtheora/fix-timeb.patch
@@ -0,0 +1,75 @@
+--- libtheora-1.1.1.orig/examples/dump_psnr.c
++++ libtheora-1.1.1/examples/dump_psnr.c
+@@ -37,7 +37,6 @@
+ #endif
+ #include <stdlib.h>
+ #include <string.h>
+-#include <sys/timeb.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ /*Yes, yes, we're going to hell.*/
+--- libtheora-1.1.1.orig/examples/dump_video.c
++++ libtheora-1.1.1/examples/dump_video.c
+@@ -37,7 +37,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <sys/timeb.h>
++#include <sys/time.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ /*Yes, yes, we're going to hell.*/
+@@ -205,9 +205,9 @@
+ int long_option_index;
+ int c;
+
+- struct timeb start;
+- struct timeb after;
+- struct timeb last;
++ struct timeval start;
++ struct timeval after;
++ struct timeval last;
+ int fps_only=0;
+ int frames = 0;
+
+@@ -418,8 +418,8 @@
+ }
+
+ if(fps_only){
+- ftime(&start);
+- ftime(&last);
++ gettimeofday(&start, NULL);
++ gettimeofday(&last, NULL);
+ }
+
+ while(!got_sigint){
+@@ -433,7 +433,7 @@
+ videobuf_ready=1;
+ frames++;
+ if(fps_only)
+- ftime(&after);
++ gettimeofday(&after, NULL);
+ }
+
+ }else
+@@ -442,16 +442,16 @@
+
+ if(fps_only && (videobuf_ready || fps_only==2)){
+ long ms =
+- after.time*1000.+after.millitm-
+- (last.time*1000.+last.millitm);
++ after.tv_sec*1000.+after.tv_usec/1000-
++ (last.tv_sec*1000.+last.tv_usec/1000);
+
+ if(ms>500 || fps_only==1 ||
+ (feof(infile) && !videobuf_ready)){
+ float file_fps = (float)ti.fps_numerator/ti.fps_denominator;
+ fps_only=2;
+
+- ms = after.time*1000.+after.millitm-
+- (start.time*1000.+start.millitm);
++ ms = after.tv_sec*1000.+after.tv_usec/1000-
++ (start.tv_sec*1000.+start.tv_usec/1000);
+
+ fprintf(stderr,"\rframe:%d rate:%.2fx ",
+ frames,