summaryrefslogtreecommitdiffstats
path: root/main/libtheora
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-08-02 10:07:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-02 10:07:09 +0000
commitfae93727d154ad73cf8be0c62dec4cd7400c07fd (patch)
tree5c7f6ffafbfa798adc84150ed710b58551dc190c /main/libtheora
parent02cf9589b27ddef1034c984d7ca89c32312a922c (diff)
downloadaports-fae93727d154ad73cf8be0c62dec4cd7400c07fd.tar.bz2
aports-fae93727d154ad73cf8be0c62dec4cd7400c07fd.tar.xz
main/libtheora: link libtheoraenc with libtheoradec
it uses a symbol there.
Diffstat (limited to 'main/libtheora')
-rw-r--r--main/libtheora/APKBUILD31
-rw-r--r--main/libtheora/enc.patch11
2 files changed, 34 insertions, 8 deletions
diff --git a/main/libtheora/APKBUILD b/main/libtheora/APKBUILD
index 700a7c79f..f306c0581 100644
--- a/main/libtheora/APKBUILD
+++ b/main/libtheora/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtheora
pkgver=1.1.1
-pkgrel=4
+pkgrel=5
pkgdesc="An open video codec developed by the Xiph.org"
url="http://www.xiph.org"
license="custom"
@@ -9,23 +9,37 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-examples"
depends=
makedepends="libvorbis-dev libogg-dev sdl-dev autoconf automake libtool"
source="http://downloads.xiph.org/releases/theora/$pkgname-$pkgver.tar.bz2
- libtheora-flags.patch"
+ libtheora-flags.patch
+ enc.patch
+ "
depends_dev="libogg-dev"
-build() {
- cd "$srcdir"/libtheora-$pkgver
- patch -p1 -i ../libtheora-flags.patch || return 1
+_builddir="$srcdir"/libtheora-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ esac
+ done
aclocal -I m4 && autoconf && automake && libtoolize || return 1
+}
+build() {
+ cd "$_builddir"
./configure --prefix=/usr \
--enable-shared \
--disable-static || return 1
+ cd lib && make || return 1
+ cd ..
make || return 1
}
package() {
- cd "$srcdir"/libtheora-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
install -m755 -d ""$pkgdir"/usr/share/licenses/$pkgname"
install -m644 LICENSE COPYING "$pkgdir"/usr/share/licenses/$pkgname/
@@ -33,11 +47,12 @@ package() {
examples() {
pkgdesc="Example applications for libtheora"
- cd "$srcdir"/libtheora-$pkgver/examples
+ cd "$_builddir"/examples
install -d "$subpkgdir"/usr/bin
install -m755 dump_psnr player_example dump_video encoder_example \
"$subpkgdir"/usr/bin/
}
md5sums="292ab65cedd5021d6b7ddd117e07cd8e libtheora-1.1.1.tar.bz2
-7cbab1ce1f52adb98e1c241515a27aca libtheora-flags.patch"
+7cbab1ce1f52adb98e1c241515a27aca libtheora-flags.patch
+5024b6c41351433bf0e8a354969f8efd enc.patch"
diff --git a/main/libtheora/enc.patch b/main/libtheora/enc.patch
new file mode 100644
index 000000000..ea604d28e
--- /dev/null
+++ b/main/libtheora/enc.patch
@@ -0,0 +1,11 @@
+--- ./lib/Makefile.am.orig
++++ ./lib/Makefile.am
+@@ -152,7 +154,7 @@
+ Version_script-enc theoraenc.exp
+ libtheoraenc_la_LDFLAGS = \
+ -version-info @THENC_LIB_CURRENT@:@THENC_LIB_REVISION@:@THENC_LIB_AGE@ \
+- @THEORAENC_LDFLAGS@ $(OGG_LIBS)
++ -ltheoradec @THEORAENC_LDFLAGS@ $(OGG_LIBS)
+
+ libtheora_la_SOURCES = \
+ $(decoder_sources) \