summaryrefslogtreecommitdiffstats
path: root/main/libvirt
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2012-10-29 14:49:51 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2012-10-29 14:50:55 +0000
commitd696bc89b69668a34ca175e3f3797a4e16aa536c (patch)
treeb3c46ccc91828a238d2c2662e2313edccc4fb0b7 /main/libvirt
parent405da0cba760d6d2da58f4a97b40ca692345d28c (diff)
downloadaports-d696bc89b69668a34ca175e3f3797a4e16aa536c.tar.bz2
aports-d696bc89b69668a34ca175e3f3797a4e16aa536c.tar.xz
main/libvirt: upgrade to 1.0.0-rc2
Diffstat (limited to 'main/libvirt')
-rw-r--r--main/libvirt/APKBUILD21
-rw-r--r--main/libvirt/libvirt-0.10.2-legacy-xen-driver.patch66
-rw-r--r--main/libvirt/libvirt-0.10.2-support-xen-sysctl-v9.patch34
-rw-r--r--main/libvirt/libvirt-1.0.0-uclibc-mkostemp.patch14
4 files changed, 25 insertions, 110 deletions
diff --git a/main/libvirt/APKBUILD b/main/libvirt/APKBUILD
index c3f24fa36..7d7579c7e 100644
--- a/main/libvirt/APKBUILD
+++ b/main/libvirt/APKBUILD
@@ -1,7 +1,10 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=libvirt
-pkgver=0.10.2
-pkgrel=5
+vmajor="1.0.0"
+vminor="rc2"
+pkgver="${vmajor}_${vminor}"
+_ver="${pkgver/_rc/-rc}"
+pkgrel=0
pkgdesc="A virtualization API for several hypervisor and container systems"
url="http://libvirt.org/"
arch="all"
@@ -15,15 +18,14 @@ makedepends="augeas-dev bridge-utils cyrus-sasl-dev device-mapper
install=
subpackages="$pkgname-client $pkgname-daemon $pkgname-dev $pkgname-doc $pkgname-lang
$pkgname-lxc $pkgname-qemu $pkgname-xen $pkgname-uml"
-source="http://libvirt.org/sources/$pkgname-$pkgver.tar.gz
+source="http://libvirt.org/sources/$pkgname-$_ver.tar.gz
libvirt.confd
libvirt.initd
- libvirt-0.10.2-legacy-xen-driver.patch
- libvirt-0.10.2-support-xen-sysctl-v9.patch
uclibc-physmem.patch
+ libvirt-1.0.0-uclibc-mkostemp.patch
"
-_builddir="$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/$pkgname-$vmajor
prepare() {
cd "$_builddir"
@@ -123,9 +125,8 @@ uml() {
_mv_driver uml
}
-md5sums="a5e50860d9da238ba270b528411c4a0d libvirt-0.10.2.tar.gz
+md5sums="77555217fc96423fa2c9fc4dbeb1febf libvirt-1.0.0-rc2.tar.gz
1c84a7baeafe0a7f4e9d7ae5180311b7 libvirt.confd
d897df38c7e7fa1a297aa551108633c9 libvirt.initd
-31c0c6ca4fe85bd1cfc00756ec47ea06 libvirt-0.10.2-legacy-xen-driver.patch
-e259b3e5b7257c9301a36186b748195b libvirt-0.10.2-support-xen-sysctl-v9.patch
-df9cbfaf8a6e520a4822914a300add4d uclibc-physmem.patch"
+df9cbfaf8a6e520a4822914a300add4d uclibc-physmem.patch
+39d0534c4e24baace260ceb6d8271ab7 libvirt-1.0.0-uclibc-mkostemp.patch"
diff --git a/main/libvirt/libvirt-0.10.2-legacy-xen-driver.patch b/main/libvirt/libvirt-0.10.2-legacy-xen-driver.patch
deleted file mode 100644
index caf17aa79..000000000
--- a/main/libvirt/libvirt-0.10.2-legacy-xen-driver.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From: Jim Fehlig <jfehlig@suse.com>
-Date: Wed, 26 Sep 2012 21:20:35 +0000 (-0600)
-Subject: Fix compilation of legacy xen driver with Xen 4.2
-X-Git-Url: http://libvirt.org/git/?p=libvirt.git;a=commitdiff_plain;h=416eca189b1934cfa8575ab72d142ec77600fcf9
-
-Fix compilation of legacy xen driver with Xen 4.2
-
-In Xen 4.2, xs.h is deprecated in favor of xenstore.h. xs.h now
-contains
-
-#warning xs.h is deprecated use xenstore.h instead
-#include <xenstore.h>
-
-which fails compilation when warnings are treated as errors.
-
-Introduce a configure-time check for xenstore.h and if found,
-use it instead of xs.h.
----
-
-diff --git a/configure.ac b/configure.ac
-index 38d94d4..ae26de7 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -768,6 +768,8 @@ if test "$with_xen" != "no" ; then
- fi
-
- if test "$with_xen" != "no" ; then
-+ dnl In Xen 4.2, xs.h is deprecated in favor of xenstore.h.
-+ AC_CHECK_HEADERS([xenstore.h])
- AC_CHECK_HEADERS([xen/xen.h xen/version.h xen/dom0_ops.h],,[
- if test "$with_xen" = "yes"; then
- fail=1
-diff --git a/src/xen/block_stats.c b/src/xen/block_stats.c
-index f3b756a..5ab1ce4 100644
---- a/src/xen/block_stats.c
-+++ b/src/xen/block_stats.c
-@@ -32,7 +32,11 @@
- # include <unistd.h>
- # include <regex.h>
-
--# include <xs.h>
-+# if HAVE_XENSTORE_H
-+# include <xenstore.h>
-+# else
-+# include <xs.h>
-+# endif
-
- # include "virterror_internal.h"
- # include "datatypes.h"
-diff --git a/src/xen/xs_internal.c b/src/xen/xs_internal.c
-index 12efa0c..a91d409 100644
---- a/src/xen/xs_internal.c
-+++ b/src/xen/xs_internal.c
-@@ -35,7 +35,11 @@
- #include <xen/dom0_ops.h>
- #include <xen/version.h>
-
--#include <xs.h>
-+#if HAVE_XENSTORE_H
-+# include <xenstore.h>
-+#else
-+# include <xs.h>
-+#endif
-
- #include "virterror_internal.h"
- #include "datatypes.h"
diff --git a/main/libvirt/libvirt-0.10.2-support-xen-sysctl-v9.patch b/main/libvirt/libvirt-0.10.2-support-xen-sysctl-v9.patch
deleted file mode 100644
index 2270075b5..000000000
--- a/main/libvirt/libvirt-0.10.2-support-xen-sysctl-v9.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From: Jim Fehlig <jfehlig@suse.com>
-Date: Wed, 26 Sep 2012 16:34:17 +0000 (-0600)
-Subject: Support Xen sysctl version 9 in Xen 4.2
-X-Git-Url: http://libvirt.org/git/?p=libvirt.git;a=commitdiff_plain;h=371ddc98664cbbd8542593e5452115ea7918dae2
-
-Support Xen sysctl version 9 in Xen 4.2
-
-Xen upstream c/s 24102:dc8e55c9 bumped the sysctl version to 9.
-Support this sysctl version in the xen_hypervisor sub-driver.
----
-
-diff --git a/src/xen/xen_hypervisor.c b/src/xen/xen_hypervisor.c
-index fdc3071..3244bbd 100644
---- a/src/xen/xen_hypervisor.c
-+++ b/src/xen/xen_hypervisor.c
-@@ -2164,6 +2164,18 @@ xenHypervisorInit(struct xenHypervisorVersions *override_versions)
- goto done;
- }
-
-+ /* Xen 4.2
-+ * sysctl version 9 -> xen-unstable c/s 24102:dc8e55c90604
-+ * domctl version 8 -> unchanged from Xen 4.1
-+ */
-+ hv_versions.sys_interface = 9; /* XEN_SYSCTL_INTERFACE_VERSION */
-+ if (virXen_getdomaininfo(fd, 0, &info) == 1) {
-+ hv_versions.dom_interface = 8; /* XEN_DOMCTL_INTERFACE_VERSION */
-+ if (virXen_getvcpusinfo(fd, 0, 0, ipt, NULL, 0) == 0){
-+ VIR_DEBUG("Using hypervisor call v2, sys ver9 dom ver8");
-+ goto done;
-+ }
-+ }
-
- /*
- * we failed to make the getdomaininfolist hypercall
diff --git a/main/libvirt/libvirt-1.0.0-uclibc-mkostemp.patch b/main/libvirt/libvirt-1.0.0-uclibc-mkostemp.patch
new file mode 100644
index 000000000..98fc07b6c
--- /dev/null
+++ b/main/libvirt/libvirt-1.0.0-uclibc-mkostemp.patch
@@ -0,0 +1,14 @@
+--- a/src/util/logging.c
++++ b/src/util/logging.c
+@@ -58,6 +58,11 @@
+
+ #define VIR_FROM_THIS VIR_FROM_NONE
+
++#ifdef __UCLIBC__
++/* uclibc does not implement mkostemp GNU extention */
++#define mkostemp(x,y) mkstemp(x)
++#endif
++
+ VIR_ENUM_DECL(virLogSource)
+ VIR_ENUM_IMPL(virLogSource, VIR_LOG_FROM_LAST,
+ "file",