summaryrefslogtreecommitdiffstats
path: root/main/libvorbis
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-27 14:19:28 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-27 14:22:26 +0000
commit1751d6595597f1d9101cac04e54f20d95790f4f4 (patch)
treee895c3aa71985691256eca03cf4f7cdfeb0d966b /main/libvorbis
parentee152f9e0dce8017d033e01e018f1482d27e7e1d (diff)
downloadaports-1751d6595597f1d9101cac04e54f20d95790f4f4.tar.bz2
aports-1751d6595597f1d9101cac04e54f20d95790f4f4.tar.xz
main/[various]: fix build against musl (add update_config_sub)
Diffstat (limited to 'main/libvorbis')
-rw-r--r--main/libvorbis/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/main/libvorbis/APKBUILD b/main/libvorbis/APKBUILD
index 8224b0a28..65fc02151 100644
--- a/main/libvorbis/APKBUILD
+++ b/main/libvorbis/APKBUILD
@@ -13,9 +13,15 @@ makedepends="$depends_dev"
#source="http://people.xiph.org/~giles/2008/$pkgname-$pkgver.tar.gz"
source="http://downloads.xiph.org/releases/vorbis/libvorbis-$pkgver.tar.gz"
-build ()
-{
- cd "$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \