summaryrefslogtreecommitdiffstats
path: root/main/mp3splt
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2012-03-17 17:49:40 +0000
committerJeff Bilyk <jbilyk@gmail.com>2012-03-17 17:49:40 +0000
commitf12d1fd4f67201554b6ae550d8800e6b979ef6f8 (patch)
tree5baa0408e5e3e01493dba9ee5731a5ae3d287ac7 /main/mp3splt
parenta6655ac9b6cad23ea5f7556a2d60b7bbaa2e1ce5 (diff)
downloadaports-f12d1fd4f67201554b6ae550d8800e6b979ef6f8.tar.bz2
aports-f12d1fd4f67201554b6ae550d8800e6b979ef6f8.tar.xz
main/{mp3splt,libmp3splt,mp3splt-gtk}: moved from testing
fixes #769
Diffstat (limited to 'main/mp3splt')
-rw-r--r--main/mp3splt/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/main/mp3splt/APKBUILD b/main/mp3splt/APKBUILD
new file mode 100644
index 000000000..b411ffee0
--- /dev/null
+++ b/main/mp3splt/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mp3splt
+pkgver=2.4
+pkgrel=0
+pkgdesc="A command-line, AlbumWrap and mp3wrap file exctractor"
+url="http://mp3splt.sourceforge.net/"
+arch="all"
+license="GPLv2"
+depends=""
+makedepends="libmp3splt-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://prdownloads.sourceforge.net/mp3splt/mp3splt-$pkgver.tar.gz"
+
+_builddir="$srcdir"/mp3splt-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --with-mp3splt-includes=/usr/include/libmp3splt \
+ --enable-oggsplt_symlink \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="aa4dc3de6e789961c71d8b3daaac0623 mp3splt-2.4.tar.gz"