summaryrefslogtreecommitdiffstats
path: root/main/nettle
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-03-19 10:59:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-03-19 10:59:42 +0000
commitbb79f08f1eadbec26ce53a5aa90550901660d56f (patch)
treea25f9e7c1f2ae1132a72a0973becb0d4dc4db9d9 /main/nettle
parente14669bdc9a17e0450b281e3b31bb2b4584230eb (diff)
downloadaports-bb79f08f1eadbec26ce53a5aa90550901660d56f.tar.bz2
aports-bb79f08f1eadbec26ce53a5aa90550901660d56f.tar.xz
main/nettle: moved from testing
Diffstat (limited to 'main/nettle')
-rw-r--r--main/nettle/APKBUILD56
-rw-r--r--main/nettle/nettle-2.4-makefile.patch11
2 files changed, 67 insertions, 0 deletions
diff --git a/main/nettle/APKBUILD b/main/nettle/APKBUILD
new file mode 100644
index 000000000..6026ccef9
--- /dev/null
+++ b/main/nettle/APKBUILD
@@ -0,0 +1,56 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch
+pkgname=nettle
+pkgver=2.4
+pkgrel=1
+pkgdesc="A low-level cryptographic library"
+url="http://www.lysator.liu.se/~nisse/nettle/"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev="gmp-dev m4"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-utils"
+source="ftp://ftp.lysator.liu.se/pub/security/lsh/$pkgname-$pkgver.tar.gz
+ nettle-2.4-makefile.patch"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-shared \
+ --disable-openssl \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+utils() {
+ pkgdesc="Utils for nettle"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+md5sums="450be8c4886d46c09f49f568ad6fa013 nettle-2.4.tar.gz
+b3a89964557b9fca040a84e9217b4b01 nettle-2.4-makefile.patch"
diff --git a/main/nettle/nettle-2.4-makefile.patch b/main/nettle/nettle-2.4-makefile.patch
new file mode 100644
index 000000000..c216365a1
--- /dev/null
+++ b/main/nettle/nettle-2.4-makefile.patch
@@ -0,0 +1,11 @@
+--- nettle-2.4/Makefile.in.orig
++++ nettle-2.4/Makefile.in
+@@ -14,7 +14,7 @@
+ INSTALL_STRIP_PROGRAM = $(INSTALL_PROGRAM) -s
+ MKDIR_P = @MKDIR_P@
+
+-SUBDIRS = tools testsuite examples
++SUBDIRS = tools testsuite
+
+ include config.make
+