summaryrefslogtreecommitdiffstats
path: root/main/nspr
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-06-26 09:38:06 +0300
committerTimo Teräs <timo.teras@iki.fi>2014-06-26 09:39:48 +0300
commit525c6ef6561b7edd68f02004716c2a36af03076c (patch)
treeffb17527323a932064c3fd6a6d4e68e26b4b0785 /main/nspr
parenta8553b29065f5164e6a06bfdc55f9616e1c38c0b (diff)
downloadaports-525c6ef6561b7edd68f02004716c2a36af03076c.tar.bz2
aports-525c6ef6561b7edd68f02004716c2a36af03076c.tar.xz
main/nspr: fix musl build to have ipv6 and large-file support
the header file tests these features using __GLIBC__ version, supply musl feature list by hand for now.
Diffstat (limited to 'main/nspr')
-rw-r--r--main/nspr/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/main/nspr/APKBUILD b/main/nspr/APKBUILD
index 531e90282..5a996bc7b 100644
--- a/main/nspr/APKBUILD
+++ b/main/nspr/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=nspr
pkgver=4.10.6
-pkgrel=0
+pkgrel=1
pkgdesc="Netscape Portable Runtime"
url="http://www.mozilla.org/projects/nspr/"
arch="all"
@@ -33,12 +33,16 @@ build() {
conf="--enable-64bit"
fi
cd "$_builddir"/build
+ # ./nspr/pr/include/md/_linux.h tests only __GLIBC__ version
+ # to detect c-library features, list musl features here for now.
+ CFLAGS="$CFLAGS -D_PR_POLL_AVAILABLE -D_PR_HAVE_OFF64_T -D_PR_INET6 -D_PR_HAVE_INET_NTOP -D_PR_HAVE_GETHOSTBYNAME2 -D_PR_HAVE_GETADDRINFO -D_PR_INET6_PROBE" \
../nspr/configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--disable-debug \
--enable-optimize \
+ --enable-ipv6 \
$conf \
|| return 1
make CC="${CC:-gcc}" CXX="${CXX:-g++}" || return 1