summaryrefslogtreecommitdiffstats
path: root/main/perl-datetime-timezone
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-03-04 11:22:43 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-03-04 11:22:43 +0200
commita263b96c26d155f20a8526a8c640469110908b0c (patch)
tree207777b05541ed6e790358e1f75296f27e39f291 /main/perl-datetime-timezone
parenta36f963facd1b2b737df1a03f756707d63a87606 (diff)
downloadaports-a263b96c26d155f20a8526a8c640469110908b0c.tar.bz2
aports-a263b96c26d155f20a8526a8c640469110908b0c.tar.xz
main/perl-datetime-timezone: break circular dependency
disable tests, and remove the circular makedependency
Diffstat (limited to 'main/perl-datetime-timezone')
-rw-r--r--main/perl-datetime-timezone/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/perl-datetime-timezone/APKBUILD b/main/perl-datetime-timezone/APKBUILD
index 17645c269..ff2857193 100644
--- a/main/perl-datetime-timezone/APKBUILD
+++ b/main/perl-datetime-timezone/APKBUILD
@@ -8,7 +8,7 @@ url="http://search.cpan.org/dist/DateTime-TimeZone/"
arch="noarch"
license="GPLv2 or Artistic"
depends="perl perl-class-load perl-params-validate perl-class-singleton"
-makedepends="perl-dev perl-datetime perl-test-requires"
+makedepends="perl-dev perl-test-requires"
install=""
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-TimeZone-$pkgver.tar.gz"
@@ -27,7 +27,11 @@ prepare() {
build() {
cd "$_builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make && make test || return 1
+
+ # No tests - tests depend on perl-datetime, but on the otherhand
+ # that package has a hard dependency on this one.
+ # Thus break circular build dependency by skipping tests.
+ make || return 1
}
package() {