summaryrefslogtreecommitdiffstats
path: root/main/perl-file-next
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-24 13:40:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-24 13:42:12 +0000
commitfd39da6470e5e7b0b1c60565a810a6fa784ab1a0 (patch)
treeb64bdef33cd8c7f59de44af4cdf2fda23e6b2d51 /main/perl-file-next
parent46ffb91c1b4cea571c72b0af1f12c999e0612285 (diff)
downloadaports-fd39da6470e5e7b0b1c60565a810a6fa784ab1a0.tar.bz2
aports-fd39da6470e5e7b0b1c60565a810a6fa784ab1a0.tar.xz
main/{ack,perl-file-next}: moved from testing
and claim maintainership
Diffstat (limited to 'main/perl-file-next')
-rw-r--r--main/perl-file-next/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/main/perl-file-next/APKBUILD b/main/perl-file-next/APKBUILD
new file mode 100644
index 000000000..43fad1795
--- /dev/null
+++ b/main/perl-file-next/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-file-next
+_pkgreal=File-Next
+pkgver=1.06
+pkgrel=0
+pkgdesc="Perl module for taint-safe file-finding"
+url="http://search.cpan.org/dist/File-Next/"
+arch="noarch"
+license="GPL PerlArtistic"
+depends=
+depends_dev=
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/P/PE/PETDANCE/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+md5sums="8d901b18e40c477acd18a6ea0fd7de64 File-Next-1.06.tar.gz"