summaryrefslogtreecommitdiffstats
path: root/main/roundcubemail
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2012-11-14 15:47:38 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2012-11-14 15:48:40 +0000
commit00403803360acda8df32228994d80ec3d48215fc (patch)
tree6dbe1d68a494cdf0c2216afd1de3071d07cd36bb /main/roundcubemail
parent03354c2a774fd1dd6ff33ee649936ff46f316635 (diff)
downloadaports-00403803360acda8df32228994d80ec3d48215fc.tar.bz2
aports-00403803360acda8df32228994d80ec3d48215fc.tar.xz
main/roundcubemail: fix compose reload bug
http://trac.roundcube.net/ticket/1488802
Diffstat (limited to 'main/roundcubemail')
-rw-r--r--main/roundcubemail/APKBUILD6
-rw-r--r--main/roundcubemail/roundcubemail_0.8.3_compose_reload_fix.patch16
2 files changed, 21 insertions, 1 deletions
diff --git a/main/roundcubemail/APKBUILD b/main/roundcubemail/APKBUILD
index b06aaa793..b43b1b896 100644
--- a/main/roundcubemail/APKBUILD
+++ b/main/roundcubemail/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=roundcubemail
pkgver=0.8.3
-pkgrel=0
+pkgrel=1
pkgdesc="A PHP web-based mail client"
url="http://www.roundcube.net"
arch="noarch"
@@ -12,17 +12,20 @@ depends="php php-imap php-xml php-json php-dom php-exif"
makedepends=""
subpackages="$pkgname-installer $pkgname-doc"
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
+ roundcubemail_0.8.3_compose_reload_fix.patch
fix-dirs.patch"
_src="$srcdir"/roundcubemail-$pkgver
prepare() {
cd "$_src"
+ ./bin/jsunshrink.sh
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ ./bin/jsshrink.sh
# fix permissions
find . -type f -print | xargs chmod a-x
@@ -74,4 +77,5 @@ installer() {
}
md5sums="4782f811d07643f0fcc9848ea4b13166 roundcubemail-0.8.3.tar.gz
+25274492462fc9d4aa1d678ebd9c84f4 roundcubemail_0.8.3_compose_reload_fix.patch
987406fd8f12719544aeb057973b368e fix-dirs.patch"
diff --git a/main/roundcubemail/roundcubemail_0.8.3_compose_reload_fix.patch b/main/roundcubemail/roundcubemail_0.8.3_compose_reload_fix.patch
new file mode 100644
index 000000000..5408c1d6a
--- /dev/null
+++ b/main/roundcubemail/roundcubemail_0.8.3_compose_reload_fix.patch
@@ -0,0 +1,16 @@
+diff --git a/program/js/app.js b/program/js/app.js
+index 4ee272c..8fe68bf 100644
+--- a/program/js/app.js
++++ b/program/js/app.js
+@@ -6145,11 +6145,6 @@ function rcube_webmail()
+ else if (request.status == 0 && status != 'abort')
+ this.display_message(this.get_label('servererror') + ' (No connection)', 'error');
+
+- // redirect to url specified in location header if not empty
+- var location_url = request.getResponseHeader("Location");
+- if (location_url != '')
+- this.redirect(location_url);
+-
+ // re-send keep-alive requests after 30 seconds
+ if (action == 'keep-alive')
+ setTimeout(function(){ ref.keep_alive(); ref.start_keepalive(); }, 30000);