summaryrefslogtreecommitdiffstats
path: root/main/roundcubemail
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2013-04-16 08:44:36 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2013-04-16 08:44:36 +0000
commit572709d3a4d5f8f0b69b6636dc27f072330d15c5 (patch)
treecb468c61dc376924bb55e1bdf126a03d9da61b35 /main/roundcubemail
parentb7bd895108436911428cbeb7c0e0148a6f285241 (diff)
downloadaports-572709d3a4d5f8f0b69b6636dc27f072330d15c5.tar.bz2
aports-572709d3a4d5f8f0b69b6636dc27f072330d15c5.tar.xz
main/roundcubemail: upgrade to 0.9.0
Diffstat (limited to 'main/roundcubemail')
-rw-r--r--main/roundcubemail/APKBUILD14
-rw-r--r--main/roundcubemail/fix-dirs.patch44
2 files changed, 14 insertions, 44 deletions
diff --git a/main/roundcubemail/APKBUILD b/main/roundcubemail/APKBUILD
index d216d6bc2..2b8b0a5a0 100644
--- a/main/roundcubemail/APKBUILD
+++ b/main/roundcubemail/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=roundcubemail
-pkgver=0.8.6
+pkgver=0.9.0
pkgrel=0
pkgdesc="A PHP web-based mail client"
url="http://www.roundcube.net"
@@ -73,9 +73,9 @@ installer() {
"$subpkgdir"/usr/share/webapps/roundcube
}
-md5sums="d8fc9958e45dccea0b016e84fde288aa roundcubemail-0.8.6.tar.gz
-987406fd8f12719544aeb057973b368e fix-dirs.patch"
-sha256sums="88128db0dc57651e08beb3c4811bc9e33aca1c39a50cfc9efb5d14b0baa17704 roundcubemail-0.8.6.tar.gz
-dcc49f9e43d443477244448ed746f86b56bbacb942adf9ca5613e8b3fb50c1a7 fix-dirs.patch"
-sha512sums="b49956ab923bee773aeaa140c24c6ca012a6fae05bb2cb664e874f4bb14436d9aaedee6c2d82638f1a1db6ab58dfd8cc3b9d0144d256d07f662565c4fa287d63 roundcubemail-0.8.6.tar.gz
-cfd169b3e15bc5ffd98179cf295311c24188e4d94278d9b8020508648abb96088fe511599bd7e2be3c3ca5948c29f4f35491e67244821c2752ddcdfe4cd20959 fix-dirs.patch"
+md5sums="843de3439886c2dddb0f09e9bb6a4d04 roundcubemail-0.9.0.tar.gz
+0cfce0716e174c27c49e1c62aa30f67c fix-dirs.patch"
+sha256sums="7edab9579cd2a6353c30de3fcfc86da231f0a46f7ad4ce707090813173f662c2 roundcubemail-0.9.0.tar.gz
+9185719a389b6cca64fc4aa73a5565858572651a71f66da0230ab180bf61e05a fix-dirs.patch"
+sha512sums="33a2026027e20f3ed8915806e0d8dcfd1f14143761b22c9bf452e7520c0b15304e74d34c524a3811a7c85e8f69bdfe40f44f0a92ff8993c94c68dfe56585da73 roundcubemail-0.9.0.tar.gz
+5c645ab7f130f8f3b17b7821e2cd0be88b6d7999da38876bde36c9b116bf7d34bcf52e2d8939d9359649e3fc5ddfb1cab7798ffb9e649be11bebd1d2c4ee006b fix-dirs.patch"
diff --git a/main/roundcubemail/fix-dirs.patch b/main/roundcubemail/fix-dirs.patch
index 0500c591b..e4a537700 100644
--- a/main/roundcubemail/fix-dirs.patch
+++ b/main/roundcubemail/fix-dirs.patch
@@ -1,21 +1,17 @@
-diff --git a/installer/index.php b/installer/index.php
-index 7ed5224..f9f8241 100644
--- a/installer/index.php
+++ b/installer/index.php
-@@ -43,7 +43,7 @@
- ini_set('display_errors', 1);
+@@ -41,7 +41,7 @@
define('INSTALL_PATH', realpath(dirname(__FILE__) . '/../').'/');
--define('RCMAIL_CONFIG_DIR', INSTALL_PATH . 'config');
-+define('RCMAIL_CONFIG_DIR', '/etc/roundcube');
- define('RCMAIL_CHARSET', 'UTF-8');
+ define('RCUBE_INSTALL_PATH', INSTALL_PATH);
+-define('RCUBE_CONFIG_DIR', INSTALL_PATH . 'config/');
++define('RCUBE_CONFIG_DIR', '/etc/roundcube');
$include_path = INSTALL_PATH . 'program/lib' . PATH_SEPARATOR;
-diff --git a/program/include/iniset.php b/program/include/iniset.php
-index 10ae11e..f9d3d92 100755
+ $include_path .= INSTALL_PATH . 'program/include' . PATH_SEPARATOR;
--- a/program/include/iniset.php
+++ b/program/include/iniset.php
-@@ -47,7 +47,7 @@ if (!defined('INSTALL_PATH')) {
+@@ -44,7 +44,7 @@
}
if (!defined('RCMAIL_CONFIG_DIR')) {
@@ -23,30 +19,4 @@ index 10ae11e..f9d3d92 100755
+ define('RCMAIL_CONFIG_DIR', '/etc/roundcube');
}
- // make sure path_separator is defined
-diff --git a/program/include/main.inc b/program/include/main.inc
-index 30d9099..8400395 100644
---- a/program/include/main.inc
-+++ b/program/include/main.inc
-@@ -2101,7 +2101,7 @@ function write_log($name, $line)
-
- // log_driver == 'file' is assumed here
- if (empty($CONFIG['log_dir']))
-- $CONFIG['log_dir'] = INSTALL_PATH.'logs';
-+ $CONFIG['log_dir'] = '/var/log/roundcube';
-
- // try to open specific log file for writing
- $logfile = $CONFIG['log_dir'].'/'.$name;
-diff --git a/program/include/rcube_config.php b/program/include/rcube_config.php
-index 7d46df0..d9990c4 100644
---- a/program/include/rcube_config.php
-+++ b/program/include/rcube_config.php
-@@ -66,7 +66,7 @@ class rcube_config
-
- // fix paths
- $this->prop['log_dir'] = $this->prop['log_dir'] ? realpath(unslashify($this->prop['log_dir'])) : INSTALL_PATH . 'logs';
-- $this->prop['temp_dir'] = $this->prop['temp_dir'] ? realpath(unslashify($this->prop['temp_dir'])) : INSTALL_PATH . 'temp';
-+ $this->prop['temp_dir'] = $this->prop['temp_dir'] ? realpath(unslashify($this->prop['temp_dir'])) : '/tmp';
-
- // fix default imap folders encoding
- foreach (array('drafts_mbox', 'junk_mbox', 'sent_mbox', 'trash_mbox') as $folder)
+ if (!defined('RCUBE_LOCALIZATION_DIR')) {