summaryrefslogtreecommitdiffstats
path: root/main/roundcubemail
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-03 14:21:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-03 14:21:05 +0000
commit7a59f50d1eafc755673137486db3357c22b0082e (patch)
tree25afca146f5da5280f50fe391dabb8f2639e5110 /main/roundcubemail
parent91ff0afcccdfcbd6fd0f50734c42e6bad56f7928 (diff)
downloadaports-7a59f50d1eafc755673137486db3357c22b0082e.tar.bz2
aports-7a59f50d1eafc755673137486db3357c22b0082e.tar.xz
main/roundcubemail: upgrade to 0.6
Diffstat (limited to 'main/roundcubemail')
-rw-r--r--main/roundcubemail/APKBUILD6
-rw-r--r--main/roundcubemail/fix-dirs.patch36
2 files changed, 22 insertions, 20 deletions
diff --git a/main/roundcubemail/APKBUILD b/main/roundcubemail/APKBUILD
index 401f87b45..908fe104f 100644
--- a/main/roundcubemail/APKBUILD
+++ b/main/roundcubemail/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=roundcubemail
-pkgver=0.5.4
+pkgver=0.6
pkgrel=0
pkgdesc="A PHP web-based mail client"
url="http://www.roundcube.net"
@@ -63,5 +63,5 @@ installer() {
"$subpkgdir"/usr/share/webapps/roundcube
}
-md5sums="a4a401b87a89eabd5e113d9e2fe2ea84 roundcubemail-0.5.4.tar.gz
-db71db7b5489ac2d0e8d80a0a8b993e0 fix-dirs.patch"
+md5sums="bdb9039d6fb95614a609aa1cb6476cf9 roundcubemail-0.6.tar.gz
+1a134edb94ff52e8a046725e485a381d fix-dirs.patch"
diff --git a/main/roundcubemail/fix-dirs.patch b/main/roundcubemail/fix-dirs.patch
index e6b8ea995..84fb97197 100644
--- a/main/roundcubemail/fix-dirs.patch
+++ b/main/roundcubemail/fix-dirs.patch
@@ -1,8 +1,21 @@
+diff --git a/installer/index.php b/installer/index.php
+index 7ed5224..f9f8241 100644
+--- a/installer/index.php
++++ b/installer/index.php
+@@ -32,7 +32,7 @@ ini_set('error_reporting', E_ALL&~E_NOTICE);
+ ini_set('display_errors', 1);
+
+ define('INSTALL_PATH', realpath(dirname(__FILE__) . '/../').'/');
+-define('RCMAIL_CONFIG_DIR', INSTALL_PATH . 'config');
++define('RCMAIL_CONFIG_DIR', '/etc/roundcube');
+
+ $include_path = INSTALL_PATH . 'program/lib' . PATH_SEPARATOR;
+ $include_path .= INSTALL_PATH . 'program' . PATH_SEPARATOR;
diff --git a/program/include/iniset.php b/program/include/iniset.php
-index 92a2d90..5f7c0ad 100755
+index 10ae11e..f9d3d92 100755
--- a/program/include/iniset.php
+++ b/program/include/iniset.php
-@@ -46,7 +46,7 @@ if (!defined('INSTALL_PATH')) {
+@@ -47,7 +47,7 @@ if (!defined('INSTALL_PATH')) {
}
if (!defined('RCMAIL_CONFIG_DIR')) {
@@ -12,10 +25,10 @@ index 92a2d90..5f7c0ad 100755
// make sure path_separator is defined
diff --git a/program/include/main.inc b/program/include/main.inc
-index 9206a62..85f9459 100644
+index 30d9099..8400395 100644
--- a/program/include/main.inc
+++ b/program/include/main.inc
-@@ -1178,7 +1178,7 @@ function write_log($name, $line)
+@@ -2101,7 +2101,7 @@ function write_log($name, $line)
// log_driver == 'file' is assumed here
if (empty($CONFIG['log_dir']))
@@ -25,7 +38,7 @@ index 9206a62..85f9459 100644
// try to open specific log file for writing
$logfile = $CONFIG['log_dir'].'/'.$name;
diff --git a/program/include/rcube_config.php b/program/include/rcube_config.php
-index 19e1be3..d362487 100644
+index 7d46df0..d9990c4 100644
--- a/program/include/rcube_config.php
+++ b/program/include/rcube_config.php
@@ -66,7 +66,7 @@ class rcube_config
@@ -34,17 +47,6 @@ index 19e1be3..d362487 100644
$this->prop['log_dir'] = $this->prop['log_dir'] ? realpath(unslashify($this->prop['log_dir'])) : INSTALL_PATH . 'logs';
- $this->prop['temp_dir'] = $this->prop['temp_dir'] ? realpath(unslashify($this->prop['temp_dir'])) : INSTALL_PATH . 'temp';
+ $this->prop['temp_dir'] = $this->prop['temp_dir'] ? realpath(unslashify($this->prop['temp_dir'])) : '/tmp';
-
+
// fix default imap folders encoding
foreach (array('drafts_mbox', 'junk_mbox', 'sent_mbox', 'trash_mbox') as $folder)
---- ./installer/index.php.orig
-+++ ./installer/index.php
-@@ -4,7 +4,7 @@
- ini_set('display_errors', 1);
-
- define('INSTALL_PATH', realpath(dirname(__FILE__) . '/../').'/');
--define('RCMAIL_CONFIG_DIR', INSTALL_PATH . 'config');
-+define('RCMAIL_CONFIG_DIR', '/etc/roundcube');
-
- $include_path = INSTALL_PATH . 'program/lib' . PATH_SEPARATOR;
- $include_path .= INSTALL_PATH . 'program' . PATH_SEPARATOR;