summaryrefslogtreecommitdiffstats
path: root/main/roundcubemail
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2012-11-15 07:54:27 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2012-11-15 07:54:27 +0000
commitf1af4245b967fd75819f9c6985b6a66c6477bd91 (patch)
tree56001b375eaaf445e4e156c4f0c07dddbe97cf96 /main/roundcubemail
parent09ed0c460397a75966aac14cc27ece0055451820 (diff)
downloadaports-f1af4245b967fd75819f9c6985b6a66c6477bd91.tar.bz2
aports-f1af4245b967fd75819f9c6985b6a66c6477bd91.tar.xz
main/roundcubemail: upgrade to 0.8.4
Diffstat (limited to 'main/roundcubemail')
-rw-r--r--main/roundcubemail/APKBUILD10
-rw-r--r--main/roundcubemail/roundcubemail_0.8.3_compose_reload_fix.patch16
2 files changed, 3 insertions, 23 deletions
diff --git a/main/roundcubemail/APKBUILD b/main/roundcubemail/APKBUILD
index b43b1b896..fe46d53ea 100644
--- a/main/roundcubemail/APKBUILD
+++ b/main/roundcubemail/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=roundcubemail
-pkgver=0.8.3
-pkgrel=1
+pkgver=0.8.4
+pkgrel=0
pkgdesc="A PHP web-based mail client"
url="http://www.roundcube.net"
arch="noarch"
@@ -12,20 +12,17 @@ depends="php php-imap php-xml php-json php-dom php-exif"
makedepends=""
subpackages="$pkgname-installer $pkgname-doc"
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
- roundcubemail_0.8.3_compose_reload_fix.patch
fix-dirs.patch"
_src="$srcdir"/roundcubemail-$pkgver
prepare() {
cd "$_src"
- ./bin/jsunshrink.sh
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
- ./bin/jsshrink.sh
# fix permissions
find . -type f -print | xargs chmod a-x
@@ -76,6 +73,5 @@ installer() {
"$subpkgdir"/usr/share/webapps/roundcube
}
-md5sums="4782f811d07643f0fcc9848ea4b13166 roundcubemail-0.8.3.tar.gz
-25274492462fc9d4aa1d678ebd9c84f4 roundcubemail_0.8.3_compose_reload_fix.patch
+md5sums="2f578c8c4741bfc43d9188923c06b638 roundcubemail-0.8.4.tar.gz
987406fd8f12719544aeb057973b368e fix-dirs.patch"
diff --git a/main/roundcubemail/roundcubemail_0.8.3_compose_reload_fix.patch b/main/roundcubemail/roundcubemail_0.8.3_compose_reload_fix.patch
deleted file mode 100644
index 5408c1d6a..000000000
--- a/main/roundcubemail/roundcubemail_0.8.3_compose_reload_fix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/program/js/app.js b/program/js/app.js
-index 4ee272c..8fe68bf 100644
---- a/program/js/app.js
-+++ b/program/js/app.js
-@@ -6145,11 +6145,6 @@ function rcube_webmail()
- else if (request.status == 0 && status != 'abort')
- this.display_message(this.get_label('servererror') + ' (No connection)', 'error');
-
-- // redirect to url specified in location header if not empty
-- var location_url = request.getResponseHeader("Location");
-- if (location_url != '')
-- this.redirect(location_url);
--
- // re-send keep-alive requests after 30 seconds
- if (action == 'keep-alive')
- setTimeout(function(){ ref.keep_alive(); ref.start_keepalive(); }, 30000);