summaryrefslogtreecommitdiffstats
path: root/main/shorewall
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-11-06 13:57:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-06 14:00:43 +0000
commit0eb75c46cc856896ec25325e1d0673b673ee639e (patch)
tree89eb416cf172e245260b2c8ce6f21f43f36e6fcb /main/shorewall
parentc235d12564297cd356a119bd694624bb85ab23a1 (diff)
downloadaports-0eb75c46cc856896ec25325e1d0673b673ee639e.tar.bz2
aports-0eb75c46cc856896ec25325e1d0673b673ee639e.tar.xz
main/shorewall*: upgrade to 4.5.21.3
fixes #1154
Diffstat (limited to 'main/shorewall')
-rw-r--r--main/shorewall/APKBUILD55
-rw-r--r--main/shorewall/shorewall.initd70
2 files changed, 115 insertions, 10 deletions
diff --git a/main/shorewall/APKBUILD b/main/shorewall/APKBUILD
index f651e79fd..4a01321a4 100644
--- a/main/shorewall/APKBUILD
+++ b/main/shorewall/APKBUILD
@@ -1,17 +1,52 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall
-pkgver=4.2.11
-pkgrel=1
-pkgdesc="Meta package for shorewall"
+pkgver=4.5.21.3
+
+_ver=$pkgver
+case $pkgver in
+*.*.*.*) _ver=${pkgver%.*};;
+esac
+
+pkgrel=0
+pkgdesc="An iptables front end for firewall configuration"
url="http://www.shorewall.net/"
-arch="all"
-license="GPL"
-depends="shorewall-shell"
-makedepends=""
-source=""
+arch="noarch"
+license="GPL-2"
+depends="shorewall-core perl iptables iproute2"
+# coreutils for install -T
+makedepends="coreutils bash"
+replaces=""
+subpackages="$pkgname-doc"
+source="http://www1.shorewall.net/pub/shorewall/${_ver%.*}/shorewall-$_ver/$pkgname-$pkgver.tar.bz2
+ shorewall.initd
+ "
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
build() {
- mkdir -p "$pkgdir"
+ cd "$_builddir"
+ ./configure MANDIR=/usr/share/man SBINDIR=/usr/sbin || return 1
+}
+
+package() {
+ cd "$_builddir"
+ DESTDIR="$pkgdir" ./install.sh || return 1
+ rm -f "$pkgdir"/etc/init.d/shorewall
+ install -m755 "$srcdir"/shorewall.initd "$pkgdir"/etc/init.d/shorewall
}
+md5sums="baa980022dc7b5ec9b0a8dcede074779 shorewall-4.5.21.3.tar.bz2
+ac54901de1e876a18d1938df1512ce0d shorewall.initd"
+sha256sums="dd1160c077112264094478ee81d83c2757d6d72d0d8e7fe6bf000427282a8356 shorewall-4.5.21.3.tar.bz2
+8a69643e09f71044b4f733263ea7120c4f6147a9d6d9b814b43e94ea64791a0f shorewall.initd"
+sha512sums="e7bc8b8f0b91ec87d2e9c51472bbe9f1e3dd367faac83d0884e4479aab94d3d742535913241d79f63c39ceb0be451ad165939145ec16cfa8e3d05ffa373c012b shorewall-4.5.21.3.tar.bz2
+c4c3a1137740fd1098680e4b362d707378a263aeeda19a846ba3007614b1b5021ee4a492a5439066b433ce1c27c5a5069a4497ac08d36959a6e1a48cb44422f4 shorewall.initd"
diff --git a/main/shorewall/shorewall.initd b/main/shorewall/shorewall.initd
new file mode 100644
index 000000000..b2809757f
--- /dev/null
+++ b/main/shorewall/shorewall.initd
@@ -0,0 +1,70 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/files/shorewall.initd,v 1.4 2013/07/13 14:09:09 constanze Exp $
+
+command=/usr/sbin/shorewall
+extra_commands="check clear"
+extra_started_commands="refresh reset safe_restart"
+
+depend() {
+ need net
+ provide firewall
+ after ulogd
+}
+
+start() {
+ checkpath -d -m 755 /var/lock/subsys
+ ebegin "Starting shorewall"
+ $command -f start 1>/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping shorewall"
+ $command stop 1>/dev/null
+ eend $?
+}
+
+safe_restart() {
+ ebegin "Safely restarting shorewall"
+ $command safe-restart 1>/dev/null
+ eend $?
+}
+
+clear() {
+ # clear will remove all the rules and bring the system to an unfirewalled
+ # state. (21 Nov 2004 eldad)
+
+ ebegin "Clearing all shorewall rules and setting policy to ACCEPT"
+ $command clear
+ eend $?
+}
+
+reset() {
+ # reset the packet and byte counters in the firewall
+
+ ebegin "Resetting the packet and byte counters in the shorewall"
+ $command reset
+ eend $?
+}
+
+refresh() {
+ # refresh the rules involving the broadcast addresses of firewall
+ # interfaces, the black list, traffic control rules and
+ # ECN control rules
+
+ ebegin "Refreshing shorewall rules"
+ $command refresh
+ eend $?
+}
+
+check() {
+ # perform cursory validation of the zones, interfaces, hosts, rules
+ # and policy files. CAUTION: does not parse and validate the generated
+ # iptables commands.
+
+ ebegin "Checking configuration files"
+ $command check
+ eend $?
+}