summaryrefslogtreecommitdiffstats
path: root/main/swfdec-mozilla
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/swfdec-mozilla
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
downloadaports-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.bz2
aports-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.xz
merged x11 repository into main
ref #255
Diffstat (limited to 'main/swfdec-mozilla')
-rw-r--r--main/swfdec-mozilla/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/swfdec-mozilla/APKBUILD b/main/swfdec-mozilla/APKBUILD
new file mode 100644
index 000000000..b2409e8da
--- /dev/null
+++ b/main/swfdec-mozilla/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=swfdec-mozilla
+pkgver=0.8.2
+pkgrel=0
+pkgdesc="free plugin for Mozilla browsers that uses the Swfdec library for playing SWF files"
+url="http://swfdec.freedesktop.org"
+license="LGPL"
+makedepends="swfdec-dev"
+depends=
+source="http://swfdec.freedesktop.org/download/$pkgname/0.8/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-static \
+ --with-plugin-dir=/usr/lib/mozilla/plugins/
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="716632e0d35b3c1582c180569ba30346 swfdec-mozilla-0.8.2.tar.gz"