summaryrefslogtreecommitdiffstats
path: root/main/sysstat
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-01-13 18:59:08 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-01-13 18:59:28 +0000
commit5f2f422fbe64f0cd09d6c441e587bae2ab6edda2 (patch)
tree0a8d53d8bdf03dc62baa17407beed0380d08e540 /main/sysstat
parent4b1862541fa07f6e0ea58d19c454609e7adaad20 (diff)
downloadaports-5f2f422fbe64f0cd09d6c441e587bae2ab6edda2.tar.bz2
aports-5f2f422fbe64f0cd09d6c441e587bae2ab6edda2.tar.xz
main/sysstat: fix musl build
Diffstat (limited to 'main/sysstat')
-rw-r--r--main/sysstat/APKBUILD31
-rw-r--r--main/sysstat/musl-fix-includes.patch30
2 files changed, 54 insertions, 7 deletions
diff --git a/main/sysstat/APKBUILD b/main/sysstat/APKBUILD
index 78c7b8c69..1bcc03e1b 100644
--- a/main/sysstat/APKBUILD
+++ b/main/sysstat/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sysstat
pkgver=10.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="Performance monitoring tools for Linux"
url="http://pagesperso-orange.fr/sebastien.godard/"
arch="all"
@@ -10,10 +10,24 @@ license="GPL"
depends=
makedepends=
subpackages="$pkgname-doc"
-source="http://pagesperso-orange.fr/sebastien.godard/sysstat-$pkgver.tar.gz"
+source="http://pagesperso-orange.fr/sebastien.godard/sysstat-$pkgver.tar.gz
+ musl-fix-includes.patch
+ "
+
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,11 +41,14 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
}
-md5sums="7a6e3df08590385113a27a76ce64a6ff sysstat-10.2.0.tar.gz"
-sha256sums="2e0fee87cec7f56ba121c320327843278e2bda30bacd54851628eab0ba09429a sysstat-10.2.0.tar.gz"
-sha512sums="d6be7332e1f4c1b5f8da5fc95f1ce3fed9658caae59fe11c1fe4cc87baf798a96bf06c28a7248a8c237b439c0c04160b5ccf4a337b84f3ba0a4623f94f9fd22c sysstat-10.2.0.tar.gz"
+md5sums="7a6e3df08590385113a27a76ce64a6ff sysstat-10.2.0.tar.gz
+64b8fd8367562adc796aaa5d9b92bcc2 musl-fix-includes.patch"
+sha256sums="2e0fee87cec7f56ba121c320327843278e2bda30bacd54851628eab0ba09429a sysstat-10.2.0.tar.gz
+80ba68b5c1cbdeb4fb6e6cd07f1ae32043126602b3c2b0864aefeb5523a3d7d5 musl-fix-includes.patch"
+sha512sums="d6be7332e1f4c1b5f8da5fc95f1ce3fed9658caae59fe11c1fe4cc87baf798a96bf06c28a7248a8c237b439c0c04160b5ccf4a337b84f3ba0a4623f94f9fd22c sysstat-10.2.0.tar.gz
+183ff89a3a0c3923b436991a2653a133942525b5f45d842ee6ed3546166211cf12828e07dc4ded2d4af8451f049ae75a87fc903a6297791034d6b304c6ef0faf musl-fix-includes.patch"
diff --git a/main/sysstat/musl-fix-includes.patch b/main/sysstat/musl-fix-includes.patch
new file mode 100644
index 000000000..f2bfceb7a
--- /dev/null
+++ b/main/sysstat/musl-fix-includes.patch
@@ -0,0 +1,30 @@
+--- sysstat-10.2.0.old/common.c
++++ sysstat-10.2.0/common.c
+@@ -29,6 +29,7 @@
+ #include <sys/types.h>
+ #include <dirent.h>
+ #include <ctype.h>
++#include <limits.h>
+ #include <libgen.h>
+
+ #include "version.h"
+--- sysstat-10.2.0.old/ioconf.c
++++ sysstat-10.2.0/ioconf.c
+@@ -26,6 +26,7 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <dirent.h>
++#include <sys/types.h>
+ #include <sys/stat.h>
+
+ #include "ioconf.h"
+--- sysstat-10.2.0.old/sa_common.c
++++ sysstat-10.2.0/sa_common.c
+@@ -27,6 +27,7 @@
+ #include <unistd.h> /* For STDOUT_FILENO, among others */
+ #include <dirent.h>
+ #include <fcntl.h>
++#include <limits.h>
+ #include <libgen.h>
+ #include <sys/types.h>
+ #include <sys/ioctl.h>