summaryrefslogtreecommitdiffstats
path: root/main/umurmur
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2014-06-24 06:49:23 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2014-06-24 06:49:23 +0000
commit14298b223f2b589dc208c258ab1329ae639f179e (patch)
tree9202604376dfeef16ce33d506b95a56258909eda /main/umurmur
parentb35496fe573fb6325d60b9d0eac151ad090bce8a (diff)
downloadaports-14298b223f2b589dc208c258ab1329ae639f179e.tar.bz2
aports-14298b223f2b589dc208c258ab1329ae639f179e.tar.xz
testing/umurmur: upgrade to 0.2.14 and move to main
Diffstat (limited to 'main/umurmur')
-rw-r--r--main/umurmur/APKBUILD65
-rw-r--r--main/umurmur/umurmur.conf58
-rw-r--r--main/umurmur/umurmur.confd3
-rw-r--r--main/umurmur/umurmur.initd19
-rwxr-xr-xmain/umurmur/umurmur.post-install4
5 files changed, 149 insertions, 0 deletions
diff --git a/main/umurmur/APKBUILD b/main/umurmur/APKBUILD
new file mode 100644
index 000000000..7d4c628c1
--- /dev/null
+++ b/main/umurmur/APKBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=umurmur
+pkgver=0.2.14
+pkgrel=0
+pkgdesc="Minimalistic Mumble server primarily targeted to run on routers"
+url="https://code.google.com/p/umurmur/"
+arch="all"
+license="Custom"
+depends=
+depends_dev=
+makedepends="$depends_dev libconfig-dev openssl-dev protobuf-c-dev"
+install="$pkgname.post-install"
+subpackages="$pkgname-doc"
+pkgusers="umurmur"
+pkggroups="umurmur"
+source="https://umurmur.googlecode.com/files/$pkgname-$pkgver.tar.gz
+ $pkgname.initd
+ $pkgname.confd
+ $pkgname.conf
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ return 0
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-ssl=openssl
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/umurmurd
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/umurmurd
+ install -m644 -D "$srcdir"/$pkgname.conf "$pkgdir"/etc/umurmur/umurmurd.conf
+ mkdir -p "$pkgdir"/usr/share/doc/umurmur
+ install -m644 -D "$_builddir"/AUTHORS "$pkgdir"/usr/share/doc/umurmur || exit 1
+ install -m644 -D "$_builddir"/ChangeLog "$pkgdir"/usr/share/doc/umurmur || exit 1
+ install -m644 -D "$_builddir"/LICENSE "$pkgdir"/usr/share/doc/umurmur || exit 1
+ install -m644 -D "$_builddir"/README.md "$pkgdir"/usr/share/doc/umurmur || exit 1
+ mkdir -p "$pkgdir"/var/run/umurmur
+ chown umurmur:umurmur "$pkgdir"/var/run/umurmur
+}
+
+md5sums="e22121b4b91f4c9de43f858f6defa0b0 umurmur-0.2.14.tar.gz
+90bc7dbe41cc03c35f691d841e489540 umurmur.initd
+355a4e8e9eda50ae72541db8da143a7f umurmur.confd
+3239959c53f9df8beeb9c1d1ba4c2cf6 umurmur.conf"
+sha256sums="4398cfc121b754277b96760eb3dd1020b5e5f497eacc16b266ea447eeacf68e9 umurmur-0.2.14.tar.gz
+459b7fe568d6b4a9c8167ed5de04c26032371e53ce38002caaab2d6340a237c3 umurmur.initd
+f7738665b9c7799df2b805f8570d4307f40c5fd3c84316e4773215b87fd57f67 umurmur.confd
+6d34c8915d7d2cbd21cdb9d3ff1f9227c48d458046481c785a260e1faeae233f umurmur.conf"
+sha512sums="88bf65119cfc7ae818c6ad0734ef2e60600826522d8133699d5f589a93b5d534183761b9aa0239ab9d3d3766b48e64fd0859bf74a280b11078e6c38da76d6835 umurmur-0.2.14.tar.gz
+b72f8b098037c016ff4baa14170262fe812a6b1188b7f38406f49423fd74c93d438439d8c5c445afc31e29a1ea674f643450ebcae9c0643fce84fea68baed215 umurmur.initd
+4af070ab4d8f4a9a2d5b59b8be95cfb49c22faae809843d9c8ede954bdf39f1224bb31cc53e5cf0f771a2033dfe904890345a6031055c9e79fdd315447e54840 umurmur.confd
+563573c405013bdf9d76003d68eb9619064659dc1e1b8b1fde24c0e587a807202bf62efe7f227cc95ff8b6db68a2ace3f0f359cef74c1bf5f1582815dd623501 umurmur.conf"
diff --git a/main/umurmur/umurmur.conf b/main/umurmur/umurmur.conf
new file mode 100644
index 000000000..cebcca28a
--- /dev/null
+++ b/main/umurmur/umurmur.conf
@@ -0,0 +1,58 @@
+# This configuration is based on the official example configuration. More information can be found
+# at http://code.google.com/p/umurmur/wiki/Configuring02x
+
+max_bandwidth = 48000;
+welcometext = "Welcome to uMurmur!";
+certificate = "/etc/umurmur/cert.crt";
+private_key = "/etc/umurmur/key.key";
+password = "";
+max_users = 10;
+
+# Specify port and/or address to bind to. Typically not needed.
+# Default is '*' for address and 64738 for port.
+# Can also be specified on the command line, which takes precedence if
+# both are specified.
+# bindport = 64738;
+# bindaddr = "192.168.1.1";
+
+# Specify this for privilege dropping. If username is specified but not
+# the groupname, the user's login group is used.
+username = "murmur";
+groupname = "murmur";
+
+# Root channel must always be defined first.
+# If a channel has a parent, the parent must be defined before the child channel(s).
+channels = ( {
+ name = "Root";
+ parent = "";
+ description = "The Root of all channels";
+ noenter = true;
+ },
+ {
+ name = "Lobby";
+ parent = "Root";
+ description = "Lobby channel";
+ },
+ {
+ name = "Red team";
+ parent = "Lobby";
+ description = "The Red team channel";
+ },
+ {
+ name = "Blue team";
+ parent = "Lobby";
+ description = "The Blue team channel";
+ }
+);
+# Channel links configuration.
+channel_links = ( {
+ source = "Lobby";
+ destination = "Red team";
+ },
+ {
+ source = "Lobby";
+ destination = "Blue team";
+ }
+);
+
+default_channel = "Lobby";
diff --git a/main/umurmur/umurmur.confd b/main/umurmur/umurmur.confd
new file mode 100644
index 000000000..d83461ce7
--- /dev/null
+++ b/main/umurmur/umurmur.confd
@@ -0,0 +1,3 @@
+# Additional flags to be passed to umurmurd
+UMURMURD_OPTS="-r"
+
diff --git a/main/umurmur/umurmur.initd b/main/umurmur/umurmur.initd
new file mode 100644
index 000000000..9d96a6f43
--- /dev/null
+++ b/main/umurmur/umurmur.initd
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/umurmur/files/umurmurd.initd,v 1.1 2013/06/20 09:10:29 polynomial-c Exp $
+
+description="umurmurd - A minimalistic mumble server"
+pidfile="/run/umurmurd/umurmurd.pid"
+command="/usr/bin/umurmurd"
+command_args="-c /etc/umurmur/umurmurd.conf -p ${pidfile} ${UMURMURD_OPTS}"
+start_stop_daemon_args="-p ${pidfile} -w 100"
+
+depend() {
+ need net
+ use logger
+}
+
+start_pre() {
+ checkpath -d -o murmur ${pidfile%/*}
+}
diff --git a/main/umurmur/umurmur.post-install b/main/umurmur/umurmur.post-install
new file mode 100755
index 000000000..4373bd7e7
--- /dev/null
+++ b/main/umurmur/umurmur.post-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+addgroup -S umurmur &>/dev/null
+adduser -s /bin/false -G umurmur -h /var/run/umurmurd -S -D umurmur &>/dev/null
+exit 0