summaryrefslogtreecommitdiffstats
path: root/main/util-linux
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-05-08 13:31:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-05-08 13:32:28 +0000
commit3c201cf3c1b78959444efa8cc2c49ecff7a6727c (patch)
tree703c6c5d56bdc986dd4169099adf51b9c6b1a7b2 /main/util-linux
parent147d8134ef3b18a894374fefb6a6f39a9918588a (diff)
downloadaports-3c201cf3c1b78959444efa8cc2c49ecff7a6727c.tar.bz2
aports-3c201cf3c1b78959444efa8cc2c49ecff7a6727c.tar.xz
main/util-linux: fix hexdump
They used invalid length modifier 'q'.
Diffstat (limited to 'main/util-linux')
-rw-r--r--main/util-linux/0001-script-fix-building-with-disable-nls.patch31
-rw-r--r--main/util-linux/APKBUILD12
-rw-r--r--main/util-linux/hexdump.patch39
3 files changed, 47 insertions, 35 deletions
diff --git a/main/util-linux/0001-script-fix-building-with-disable-nls.patch b/main/util-linux/0001-script-fix-building-with-disable-nls.patch
deleted file mode 100644
index d81efd330..000000000
--- a/main/util-linux/0001-script-fix-building-with-disable-nls.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From c22a5aaf45d21487641080d185e175d7d78d65d1 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Tue, 30 Aug 2011 07:55:17 +0000
-Subject: [PATCH] script: fix building with --disable-nls
-
-We should only include the libintl.h when NLS is requested.
-
-This fixes issue when building util-linux with uClibc.
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- term-utils/script.c | 2 ++
- 1 files changed, 2 insertions(+), 0 deletions(-)
-
-diff --git a/term-utils/script.c b/term-utils/script.c
-index d96ca2f..99748a1 100644
---- a/term-utils/script.c
-+++ b/term-utils/script.c
-@@ -55,7 +55,9 @@
- #include <getopt.h>
- #include <unistd.h>
- #include <fcntl.h>
-+#ifdef ENABLE_NLS
- #include <libintl.h>
-+#endif
- #include <limits.h>
- #include <locale.h>
- #include <stddef.h>
---
-1.7.6.1
-
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index 5ed17576c..2af38def8 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -8,7 +8,7 @@ case $pkgver in
*.*) _v=$pkgver;;
esac
-pkgrel=1
+pkgrel=2
pkgdesc="Random collection of Linux utilities"
url="http://kernel.org/~kzak/util-linux/"
arch="all"
@@ -20,6 +20,7 @@ install=
source="http://www.kernel.org/pub/linux/utils/util-linux/v${_v}/util-linux-$pkgver.tar.xz
fix-setenv-usage.patch
ttydefaults.h
+ hexdump.patch
"
subpackages="$pkgname-doc $pkgname-dev libuuid libblkid libmount sfdisk cfdisk
mcookie blkid"
@@ -126,10 +127,13 @@ mcookie() {
md5sums="3f191727a0d28f7204b755cf1b6ea0aa util-linux-2.24.2.tar.xz
7033d8ec10f6ff52c8120afbe9522490 fix-setenv-usage.patch
-6196f1ce853dfaf717569c1e35555d6d ttydefaults.h"
+6196f1ce853dfaf717569c1e35555d6d ttydefaults.h
+38df779dea96dcbad8cf6c47eda19fd5 hexdump.patch"
sha256sums="1243d6c07f1c5b38aa4c3814c81a71c24cba7dafe08942916bf216a90a460ff0 util-linux-2.24.2.tar.xz
ff1625c8d479511b263c1beb86bf6c30c2e13142183647f4fa8c62ff1bc68910 fix-setenv-usage.patch
-46faf1198bd884d12c5d45019a5fec8dfdefeae6721d8c9f3da89921acdb2a6d ttydefaults.h"
+46faf1198bd884d12c5d45019a5fec8dfdefeae6721d8c9f3da89921acdb2a6d ttydefaults.h
+c0b563541241ea68693c5b84e2cd83df7084bea3d01f4fcb33fc2e766474e404 hexdump.patch"
sha512sums="a0c03876ef19fa09e434e3e5362fb3f3e0a254b3b39a623ac7a9a207d06afce00366792244ed0fac86931f8340c046620660f33c3444a07a12037182fc191240 util-linux-2.24.2.tar.xz
310acfe2f171010014d25b1788ea64bffc5a315f4fef8d3b8fc9b003bda8810111b12987052eb2d5856500bd6b742792c977608fe9459ce2efe7545ef0054588 fix-setenv-usage.patch
-876bb9041eca1b2cca1e9aac898f282db576f7860aba690a95c0ac629d7c5b2cdeccba504dda87ff55c2a10b67165985ce16ca41a0694a267507e1e0cafd46d9 ttydefaults.h"
+876bb9041eca1b2cca1e9aac898f282db576f7860aba690a95c0ac629d7c5b2cdeccba504dda87ff55c2a10b67165985ce16ca41a0694a267507e1e0cafd46d9 ttydefaults.h
+ddb9ca291644c1fcc00960f4963dfe3a646859895b1bc10f3b892f34c387fe73881ca5076c6ad4009ffb876bca3ff658760a864f83b5c467f6023000dcb304fc hexdump.patch"
diff --git a/main/util-linux/hexdump.patch b/main/util-linux/hexdump.patch
new file mode 100644
index 000000000..72966e627
--- /dev/null
+++ b/main/util-linux/hexdump.patch
@@ -0,0 +1,39 @@
+--- ./text-utils/parse.c.orig
++++ ./text-utils/parse.c
+@@ -208,7 +208,7 @@
+ PR *pr, **nextpr;
+ FU *fu;
+ char *p1, *p2;
+- char savech, *fmtp, cs[3];
++ char savech, *fmtp, cs[4];
+ int nconv, prec;
+
+ nextpr = NULL;
+@@ -282,9 +282,10 @@
+ goto isint;
+ case 'o': case 'u': case 'x': case 'X':
+ pr->flags = F_UINT;
+-isint: cs[2] = '\0';
+- cs[1] = cs[0];
+- cs[0] = 'q';
++isint: cs[3] = '\0';
++ cs[2] = cs[0];
++ cs[1] = 'l';
++ cs[0] = 'l';
+ switch(fu->bcnt) {
+ case 0: case 4:
+ pr->bcnt = 4;
+@@ -342,9 +343,10 @@
+ ++p2;
+ switch(p1[2]) {
+ case 'd': case 'o': case'x':
+- cs[0] = 'q';
+- cs[1] = p1[2];
+- cs[2] = '\0';
++ cs[0] = 'l';
++ cs[1] = 'l';
++ cs[2] = p1[2];
++ cs[3] = '\0';
+ break;
+ default:
+ p1[3] = '\0';