summaryrefslogtreecommitdiffstats
path: root/main/util-linux
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-07-17 13:43:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-07-17 13:45:36 +0000
commit80f5ac62c11a29201922a51d941e60b4dfa104c2 (patch)
tree4dd12abbc70220e8030fb1193006c4a0f1b868d3 /main/util-linux
parent6c0821123b75c6e217711078b595ecd76ee6fa9a (diff)
downloadaports-80f5ac62c11a29201922a51d941e60b4dfa104c2.tar.bz2
aports-80f5ac62c11a29201922a51d941e60b4dfa104c2.tar.xz
main/util-linux: suppress warning with --quiet
ref #3099
Diffstat (limited to 'main/util-linux')
-rw-r--r--main/util-linux/0001-sfdisk-suppress-warning-about-missing-boot-partition.patch31
-rw-r--r--main/util-linux/APKBUILD12
2 files changed, 39 insertions, 4 deletions
diff --git a/main/util-linux/0001-sfdisk-suppress-warning-about-missing-boot-partition.patch b/main/util-linux/0001-sfdisk-suppress-warning-about-missing-boot-partition.patch
new file mode 100644
index 000000000..643c06349
--- /dev/null
+++ b/main/util-linux/0001-sfdisk-suppress-warning-about-missing-boot-partition.patch
@@ -0,0 +1,31 @@
+From 7f7379b7628f5572e752069276f35e4d32ad884d Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 17 Jul 2014 13:37:33 +0000
+Subject: [PATCH] sfdisk: suppress warning about missing boot partition with
+ --quiet
+
+Many use grub or lilo which does not care about boot partition. It
+might also be that sfdisk is used to partition a data disk from a
+script, so we hid the warning with --quiet.
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ disk-utils/sfdisk.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/disk-utils/sfdisk.c b/disk-utils/sfdisk.c
+index b462705..95dbb45 100644
+--- a/fdisks/sfdisk.c
++++ b/fdisks/sfdisk.c
+@@ -1324,7 +1324,7 @@ partitions_ok(int fd, struct disk_desc *z) {
+ break;
+ }
+ }
+- if (pno == -1 || pno >= 4)
++ if (!quiet && (pno == -1 || pno >= 4))
+ warnx(_("Warning: no primary partition is marked bootable (active)\n"
+ "This does not matter for LILO, but the DOS MBR will "
+ "not boot this disk."));
+--
+2.0.1
+
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index cb7ee87f9..f3771b524 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -8,7 +8,7 @@ case $pkgver in
*.*) _v=$pkgver;;
esac
-pkgrel=3
+pkgrel=4
pkgdesc="Random collection of Linux utilities"
url="http://kernel.org/~kzak/util-linux/"
arch="all"
@@ -21,6 +21,7 @@ source="http://www.kernel.org/pub/linux/utils/util-linux/v${_v}/util-linux-$pkgv
fix-setenv-usage.patch
ttydefaults.h
hexdump.patch
+ 0001-sfdisk-suppress-warning-about-missing-boot-partition.patch
"
subpackages="$pkgname-doc $pkgname-dev libuuid libblkid libmount sfdisk cfdisk
mcookie blkid"
@@ -129,12 +130,15 @@ mcookie() {
md5sums="3f191727a0d28f7204b755cf1b6ea0aa util-linux-2.24.2.tar.xz
7033d8ec10f6ff52c8120afbe9522490 fix-setenv-usage.patch
6196f1ce853dfaf717569c1e35555d6d ttydefaults.h
-38df779dea96dcbad8cf6c47eda19fd5 hexdump.patch"
+38df779dea96dcbad8cf6c47eda19fd5 hexdump.patch
+d3cc2a2b7e3cc0d2a67efda266edad0b 0001-sfdisk-suppress-warning-about-missing-boot-partition.patch"
sha256sums="1243d6c07f1c5b38aa4c3814c81a71c24cba7dafe08942916bf216a90a460ff0 util-linux-2.24.2.tar.xz
ff1625c8d479511b263c1beb86bf6c30c2e13142183647f4fa8c62ff1bc68910 fix-setenv-usage.patch
46faf1198bd884d12c5d45019a5fec8dfdefeae6721d8c9f3da89921acdb2a6d ttydefaults.h
-c0b563541241ea68693c5b84e2cd83df7084bea3d01f4fcb33fc2e766474e404 hexdump.patch"
+c0b563541241ea68693c5b84e2cd83df7084bea3d01f4fcb33fc2e766474e404 hexdump.patch
+580247343f34919d080cf469e8f797c29d14c041948e212222f6d9ce6cd42495 0001-sfdisk-suppress-warning-about-missing-boot-partition.patch"
sha512sums="a0c03876ef19fa09e434e3e5362fb3f3e0a254b3b39a623ac7a9a207d06afce00366792244ed0fac86931f8340c046620660f33c3444a07a12037182fc191240 util-linux-2.24.2.tar.xz
310acfe2f171010014d25b1788ea64bffc5a315f4fef8d3b8fc9b003bda8810111b12987052eb2d5856500bd6b742792c977608fe9459ce2efe7545ef0054588 fix-setenv-usage.patch
876bb9041eca1b2cca1e9aac898f282db576f7860aba690a95c0ac629d7c5b2cdeccba504dda87ff55c2a10b67165985ce16ca41a0694a267507e1e0cafd46d9 ttydefaults.h
-ddb9ca291644c1fcc00960f4963dfe3a646859895b1bc10f3b892f34c387fe73881ca5076c6ad4009ffb876bca3ff658760a864f83b5c467f6023000dcb304fc hexdump.patch"
+ddb9ca291644c1fcc00960f4963dfe3a646859895b1bc10f3b892f34c387fe73881ca5076c6ad4009ffb876bca3ff658760a864f83b5c467f6023000dcb304fc hexdump.patch
+a744ffa53e8a92c996adcabd9ac63aebda1ec1b6776addc7f29ff2262f066e7e20cc7b0ea67d42b52f0207fdaad0195b3b9901fb407f942b92b263a35ec47949 0001-sfdisk-suppress-warning-about-missing-boot-partition.patch"