summaryrefslogtreecommitdiffstats
path: root/main/wireshark/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-02 09:38:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-02 09:38:40 +0000
commit37fc6310509c4832e1ea26882970171428ddcb1a (patch)
treeede946ed54802821cc6ee18011882233f0c1ce9b /main/wireshark/APKBUILD
parent607d2b046a7376cb5b9b3becec948ffe059a8d6d (diff)
downloadaports-37fc6310509c4832e1ea26882970171428ddcb1a.tar.bz2
aports-37fc6310509c4832e1ea26882970171428ddcb1a.tar.xz
main/wireshark: upgrade to 1.2.8
Diffstat (limited to 'main/wireshark/APKBUILD')
-rw-r--r--main/wireshark/APKBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/main/wireshark/APKBUILD b/main/wireshark/APKBUILD
index bd315fa3b..7aeb2803e 100644
--- a/main/wireshark/APKBUILD
+++ b/main/wireshark/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Jeremy Thomerson <jeremy@thomersonfamily.com>
# Maintainer: Jeremy Thomerson <jeremy@thomersonfamily.com>
pkgname=wireshark
-pkgver=1.2.6
-pkgrel=2
+pkgver=1.2.8
+pkgrel=0
pkgdesc="network protocol analyzer - GTK version"
url="http://www.wireshark.org"
license="GPLv2"
@@ -12,10 +12,19 @@ makedepends="bison flex perl glib glib-dev pkgconfig libpcap-dev libcap-dev
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-common tshark"
source="http://www.wireshark.org/download/src/${pkgname}-${pkgver}.tar.bz2
+ wireshark-1.1.2--as-needed.patch
+ wireshark-1.2.8-zlib-1.2.5-capture.patch
wireshark.desktop
wireshark.png"
# depends_dev="somepackage-dev"
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in "$srcdir"/*.patch; do
+ msg "Applying $i"
+ patch -p1 -i "$i" || return 1
+ done
+}
build() {
cd "$srcdir"/$pkgname-$pkgver
@@ -64,6 +73,8 @@ tshark() {
mv "$pkgdir"/usr/bin/tshark "$subpkgdir"/usr/bin/tshark
}
-md5sums="f3e0917ed393366bbf96c53b58cb0931 wireshark-1.2.6.tar.bz2
+md5sums="3a75d4f62317e52b8b39a1e9e37f1553 wireshark-1.2.8.tar.bz2
+cc87d7eb31f256df751b3371b1c426e9 wireshark-1.1.2--as-needed.patch
+cc4fbe2db149f2ee42dd0593944a69fe wireshark-1.2.8-zlib-1.2.5-capture.patch
504ede44c02b2a52f6cbd3bffdf93b8d wireshark.desktop
e771800a8c977fe223583a453bc27397 wireshark.png"