summaryrefslogtreecommitdiffstats
path: root/main/xf86-video-chips
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-03-07 09:28:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-03-07 18:23:43 +0000
commitc0b931cbafc37091dd940162bbc0e5e08b554e3a (patch)
tree283a0b897e6d72eddbb5987fb4abb9bf58c8c3a6 /main/xf86-video-chips
parent4fc10f336cb8bdcd3c5ea6e46adc9b7da5b45415 (diff)
downloadaports-c0b931cbafc37091dd940162bbc0e5e08b554e3a.tar.bz2
aports-c0b931cbafc37091dd940162bbc0e5e08b554e3a.tar.xz
main/xf86-video-chips: rebuild against xorg-server-1.14
Diffstat (limited to 'main/xf86-video-chips')
-rw-r--r--main/xf86-video-chips/APKBUILD10
-rw-r--r--main/xf86-video-chips/mibstore.patch39
2 files changed, 48 insertions, 1 deletions
diff --git a/main/xf86-video-chips/APKBUILD b/main/xf86-video-chips/APKBUILD
index e97560b25..9b739621a 100644
--- a/main/xf86-video-chips/APKBUILD
+++ b/main/xf86-video-chips/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-chips
pkgver=1.2.5
-pkgrel=1
+pkgrel=3
pkgdesc="Chips and Technologies video driver"
url="http://xorg.freedesktop.org/"
arch="all"
@@ -12,6 +12,7 @@ makedepends="pkgconfig xorg-server-dev libxi-dev fontsproto randrproto
videoproto renderproto"
source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
+ mibstore.patch
iopl.h"
prepare() {
@@ -37,4 +38,11 @@ package() {
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
md5sums="56be62612f98a0cf469a2a78c0a14ed5 xf86-video-chips-1.2.5.tar.bz2
+d778298220dd261af852b50d986f72ca mibstore.patch
e4a7c922ab37bb4c8f44f731c9bec911 iopl.h"
+sha256sums="8d3c744d035b3d769049647bb8022ec24500d31b1b224cd0ea4efe61f86bfed2 xf86-video-chips-1.2.5.tar.bz2
+36165ebc70926ab5a8fe4331c5ce88c7f5f2e6979170b849ac1c2c99b3d1a804 mibstore.patch
+d04607e51f9064fb128beceda9660feadb7775b585466a5b9fb04f942effc670 iopl.h"
+sha512sums="3468d453fb3bc01b115d0a4a9f10bebe43b89c9cd997e2991d459a40a2f8a0e3ed2cb40bfcb2b80fae853af8c9ea6a94c82d73d16a27fe9612c8a1f2a6fbd3d4 xf86-video-chips-1.2.5.tar.bz2
+b2ef8a538fd5764d072a1310f80bd1f7f7886adf5ffcacf1f2dcc58b054e91ad88a9aad262e8c5494ee4d29471d0e771bd8792f4760680efa16f6d177a932f44 mibstore.patch
+9fc3dbf8325425b755b08e9478225872468cacda5c97a2eb0c987bf0c726ca89d559d8db9d00ac372c52b8bd55912a9fa20f60eb4bdd2a2df093857a0023714c iopl.h"
diff --git a/main/xf86-video-chips/mibstore.patch b/main/xf86-video-chips/mibstore.patch
new file mode 100644
index 000000000..bfd94181e
--- /dev/null
+++ b/main/xf86-video-chips/mibstore.patch
@@ -0,0 +1,39 @@
+From 151a1ec855a9ada44907cb6bef06a71e9080504b Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 25 Sep 2012 12:54:34 +0000
+Subject: Remove mibstore.h
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+---
+diff --git a/src/ct_driver.c b/src/ct_driver.c
+index 6f3a5d4..effbc60 100644
+--- a/src/ct_driver.c
++++ b/src/ct_driver.c
+@@ -96,9 +96,6 @@
+ /* All drivers initialising the SW cursor need this */
+ #include "mipointer.h"
+
+-/* All drivers implementing backing store need this */
+-#include "mibstore.h"
+-
+ /* All drivers using the mi banking wrapper need this */
+ #ifdef HAVE_ISA
+ #include "mibank.h"
+@@ -4145,7 +4142,6 @@ CHIPSScreenInit(SCREEN_INIT_ARGS_DECL)
+ pBankInfo = NULL;
+ return FALSE;
+ }
+- miInitializeBackingStore(pScreen);
+ xf86SetBackingStore(pScreen);
+
+ /* Initialise cursor functions */
+@@ -4296,7 +4292,6 @@ CHIPSScreenInit(SCREEN_INIT_ARGS_DECL)
+ }
+ }
+
+- miInitializeBackingStore(pScreen);
+ xf86SetBackingStore(pScreen);
+ #ifdef ENABLE_SILKEN_MOUSE
+ xf86SetSilkenMouse(pScreen);
+--
+cgit v0.9.0.2-2-gbebe