summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2014-07-29 07:53:34 +0000
committerEivind Uggedal <eivind@uggedal.com>2014-07-29 07:53:34 +0000
commitf767b1d8e02fe18d6eea7f0364e0c8649b8cb5a7 (patch)
tree60e73be14c88a461e45c37414f1bda57e510d1a2 /main
parent89b95456db418c6a7e5902243c0b6a14106ad406 (diff)
downloadaports-f767b1d8e02fe18d6eea7f0364e0c8649b8cb5a7.tar.bz2
aports-f767b1d8e02fe18d6eea7f0364e0c8649b8cb5a7.tar.xz
main/fcgiwrap: moved from testing
Diffstat (limited to 'main')
-rw-r--r--main/fcgiwrap/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/main/fcgiwrap/APKBUILD b/main/fcgiwrap/APKBUILD
new file mode 100644
index 000000000..44fc3fc96
--- /dev/null
+++ b/main/fcgiwrap/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Eivind Uggedal <eivind@uggedal.com>
+pkgname=fcgiwrap
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Simple server for running CGI applications over FastCGI"
+url="https://nginx.localdomain.pl/wiki/FcgiWrap"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev autoconf libtool automake fcgi-dev"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gnosek/$pkgname/archive/$pkgver.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$_builddir"
+
+ autoreconf --install && \
+ ./configure --prefix=/usr --mandir=/share/man --sbindir=/bin && \
+ make
+}
+
+package() {
+ cd "$_builddir"
+
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="d14f56bda6758a6e02aa7b3fb125cbce fcgiwrap-1.1.0.tar.gz"
+sha256sums="4c7de0db2634c38297d5fcef61ab4a3e21856dd7247d49c33d9b19542bd1c61f fcgiwrap-1.1.0.tar.gz"
+sha512sums="b8d35762d1d3c94a67602290b0092f0c38cffbbcd3dbc16597abf8b92172909b04450c238de2e430e841a17dd47fdd48d6a001f77539966980ef1af61e447ddc fcgiwrap-1.1.0.tar.gz"