summaryrefslogtreecommitdiffstats
path: root/testing/chntpw
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-06-02 18:20:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-06-02 18:20:59 +0000
commit653c0a58d564548fe8ba49fc50ffc85a08553576 (patch)
tree324ffdbd88d8d1972881c57e2465f53445c11c6f /testing/chntpw
parent96a06c6a33bfb4cd431f76c30a024eb4cd14b9b6 (diff)
downloadaports-653c0a58d564548fe8ba49fc50ffc85a08553576.tar.bz2
aports-653c0a58d564548fe8ba49fc50ffc85a08553576.tar.xz
testing/chntpw: upgrade to 140201
Diffstat (limited to 'testing/chntpw')
-rw-r--r--testing/chntpw/APKBUILD15
-rw-r--r--testing/chntpw/stdint.patch11
2 files changed, 21 insertions, 5 deletions
diff --git a/testing/chntpw/APKBUILD b/testing/chntpw/APKBUILD
index c88a8f4ed..f95508d29 100644
--- a/testing/chntpw/APKBUILD
+++ b/testing/chntpw/APKBUILD
@@ -1,7 +1,7 @@
# Contributor:
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=chntpw
-pkgver=110511
+pkgver=140201
pkgrel=0
pkgdesc="Change passwords in Windows SAM files"
url="http://pogostick.net/~pnh/ntpasswd/"
@@ -12,7 +12,9 @@ depends_dev=""
makedepends="$depends_dev openssl-dev"
install=""
subpackages=""
-source="http://pogostick.net/~pnh/ntpasswd/$pkgname-source-$pkgver.zip"
+source="http://pogostick.net/~pnh/ntpasswd/$pkgname-source-$pkgver.zip
+ stdint.patch
+ "
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -37,6 +39,9 @@ package() {
install chntpw cpnt reged "$pkgdir"/usr/bin/
}
-md5sums="a3fb358d1adec589cd6bc8dedf68896c chntpw-source-110511.zip"
-sha256sums="593514ca8601adb4091d951499b916dfdac2bd34b325d307237fa52ca572b5b7 chntpw-source-110511.zip"
-sha512sums="2a0b3638df40481d0650a5fb524b37896db253db83eb8e12836a3f59f12df59bea89ae92710e28bd08dc01f6fa806789be118397fd097732f7132571d3057d56 chntpw-source-110511.zip"
+md5sums="d60bc657206b07ad84d926649d6417dc chntpw-source-140201.zip
+7219b4f860212e85de39ba1937e2c296 stdint.patch"
+sha256sums="96e20905443e24cba2f21e51162df71dd993a1c02bfa12b1be2d0801a4ee2ccc chntpw-source-140201.zip
+9d392cdf598d4a9e9ddd3ae1b538ed1d8bd63fb27e23d4e4c9b13110b808a723 stdint.patch"
+sha512sums="a26d747f6e077d1bb3e9b8077781f8c37dd978e07b7426495862f15c9004572b706c34736fc4d1ed8856b1a43335d726b4d87c688f7f9a11fd6cc3a74d71a7fa chntpw-source-140201.zip
+3ed747119d125b3e4dc8dbb2a697d411ef2f4403ec84c60177d8e35389bc695bb0c65f7aa4314ca320ffceec87e60e2a0c81d52544b90463fe23aa7d4a50df67 stdint.patch"
diff --git a/testing/chntpw/stdint.patch b/testing/chntpw/stdint.patch
new file mode 100644
index 000000000..841e25ed7
--- /dev/null
+++ b/testing/chntpw/stdint.patch
@@ -0,0 +1,11 @@
+--- ./ntreg.h.orig
++++ ./ntreg.h
+@@ -25,6 +25,8 @@
+ #ifndef _INCLUDE_NTREG_H
+ #define _INCLUDE_NTREG_H 1
+
++#include <stdint.h>
++
+ #define SZ_MAX 4096 /* Max unicode strlen before we truncate */
+
+ #define KEY_ROOT 0x2c /* Type ID of ROOT key node */