summaryrefslogtreecommitdiffstats
path: root/testing/flashcache-grsec/depmod.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-15 11:25:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-15 11:25:45 +0000
commitb6a53db259db21259a6256d9c0dcb2a8be8b14c5 (patch)
treef90406ff1db3c00bbe39d1b38b68c57fd21483c1 /testing/flashcache-grsec/depmod.patch
parentec7cc3fea1209aae720efdf642c3ed4f8aca546e (diff)
downloadaports-b6a53db259db21259a6256d9c0dcb2a8be8b14c5.tar.bz2
aports-b6a53db259db21259a6256d9c0dcb2a8be8b14c5.tar.xz
testing/flashcache-grsec: new aport
a general purpose writeback block cache for Linux https://github.com/facebook/flashcache/ ref #2221
Diffstat (limited to 'testing/flashcache-grsec/depmod.patch')
-rw-r--r--testing/flashcache-grsec/depmod.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/testing/flashcache-grsec/depmod.patch b/testing/flashcache-grsec/depmod.patch
new file mode 100644
index 000000000..15c061505
--- /dev/null
+++ b/testing/flashcache-grsec/depmod.patch
@@ -0,0 +1,20 @@
+--- ./src/Makefile.orig 2013-08-15 11:20:54.575932175 +0000
++++ ./src/Makefile 2013-08-15 11:21:37.813472296 +0000
+@@ -24,6 +24,8 @@
+ KERNEL_TREE := $(RHEL5_TREE)
+ endif
+
++DEPMOD ?= depmod
++
+ obj-m += flashcache.o
+ flashcache-objs := flashcache_conf.o flashcache_main.o flashcache_subr.o flashcache_ioctl.o flashcache_procfs.o
+
+@@ -42,7 +44,7 @@
+ modules_install: modules
+ install -o root -g root -m 0755 -d $(DESTDIR)/lib/modules/$(KERNEL_SOURCE_VERSION)/extra/flashcache/
+ install -o root -g root -m 0755 flashcache.ko $(DESTDIR)/lib/modules/$(KERNEL_SOURCE_VERSION)/extra/flashcache/
+- depmod -a $(KERNEL_SOURCE_VERSION)
++ $(DEPMOD) -a $(KERNEL_SOURCE_VERSION)
+
+ .PHONY: utils_install
+ utils_install: utils