summaryrefslogtreecommitdiffstats
path: root/testing/haproxy/APKBUILD
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-08-25 22:59:14 +0000
committerMichael Mason <ms13sp@gmail.com>2009-08-25 22:59:14 +0000
commitd9ce4aad94e38485419d91c49b4eb6a71d44cae7 (patch)
treede2539c81bfb8e1898009211b477f8c749ea3b82 /testing/haproxy/APKBUILD
parent708332729740e2d54c18d71d2cacbe20d65f7cc2 (diff)
downloadaports-d9ce4aad94e38485419d91c49b4eb6a71d44cae7.tar.bz2
aports-d9ce4aad94e38485419d91c49b4eb6a71d44cae7.tar.xz
unstables/haproxy moved to testing/haproxy
Diffstat (limited to 'testing/haproxy/APKBUILD')
-rw-r--r--testing/haproxy/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/haproxy/APKBUILD b/testing/haproxy/APKBUILD
new file mode 100644
index 000000000..d37caf880
--- /dev/null
+++ b/testing/haproxy/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=haproxy
+pkgver=1.3.20
+pkgrel=0
+pkgdesc="A TCP/HTTP reverse proxy for high availability environments"
+url="http://haproxy.1wt.eu"
+license="GPL"
+depends=""
+makedepends=""
+install=
+subpackages=""
+source="http://haproxy.1wt.eu/download/1.3/src/$pkgname-$pkgver.tar.gz
+ haproxy.initd"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make TARGET=linux26 || return 1
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="e37046e0cb2f407d92c41d7731d1dd10 haproxy-1.3.20.tar.gz
+a7c6178dc4078fa233084ee36c8b440c haproxy.initd"