summaryrefslogtreecommitdiffstats
path: root/testing/haproxy
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2011-03-01 17:23:46 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-03-01 17:32:35 -0600
commit7d4cb2c3aeef2c99fb4f2fe8e1d7c9ff459d0028 (patch)
treec8f1b42f3868dac515d2ccf730cdee7550ce4aa8 /testing/haproxy
parent7ea73ac580e196b273dab710d5f2edee708ce36e (diff)
downloadaports-7d4cb2c3aeef2c99fb4f2fe8e1d7c9ff459d0028.tar.bz2
aports-7d4cb2c3aeef2c99fb4f2fe8e1d7c9ff459d0028.tar.xz
main/haproxy: moved from testing
move haproxy from testing to main
Diffstat (limited to 'testing/haproxy')
-rw-r--r--testing/haproxy/APKBUILD29
-rw-r--r--testing/haproxy/haproxy.initd45
2 files changed, 0 insertions, 74 deletions
diff --git a/testing/haproxy/APKBUILD b/testing/haproxy/APKBUILD
deleted file mode 100644
index 9f8355de7..000000000
--- a/testing/haproxy/APKBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# Contributor: Jeff Bilyk <jbilyk@gmail.com>
-# Maintainer: Michael Mason <ms13sp@gmail.com>
-pkgname=haproxy
-pkgver=1.4.10
-pkgrel=1
-pkgdesc="A TCP/HTTP reverse proxy for high availability environments"
-url="http://haproxy.1wt.eu"
-arch="all"
-license="GPL"
-depends=""
-makedepends=""
-install=
-subpackages=""
-source="http://haproxy.1wt.eu/download/1.4/src/$pkgname-$pkgver.tar.gz
- haproxy.initd"
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- make TARGET=linux26 || return 1
-}
-
-package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir" PREFIX=/usr install
- install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
-}
-
-md5sums="c35a7b7820d6da6c34cfd952805b4e85 haproxy-1.4.10.tar.gz
-cce88addaac6ee8065633b94c404300d haproxy.initd"
diff --git a/testing/haproxy/haproxy.initd b/testing/haproxy/haproxy.initd
deleted file mode 100644
index 68b7e0fef..000000000
--- a/testing/haproxy/haproxy.initd
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/net-proxy/haproxy/files/haproxy.initd,v 1.3 2007/10/27 10:42:32 mrness Exp $
-
-opts="${opts} reload"
-
-CONFFILE=/etc/${SVCNAME}.cfg
-PIDFILE=/var/run/${SVCNAME}.pid
-
-checkconfig() {
- if [ ! -f "${CONFFILE}" ]; then
- eerror "${CONFFILE} does not exist!"
- return 1
- fi
- /usr/sbin/haproxy -c -f "${CONFFILE}" >/dev/null
-}
-
-depend() {
- need net
- after firewall
- use dns logger
-}
-
-start() {
- checkconfig || return 1
-
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --quiet \
- --exec /usr/sbin/haproxy \
- -- -D -p "${PIDFILE}" -f "${CONFFILE}"
- eend ${?}
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --quiet --pidfile "${PIDFILE}"
- eend ${?}
-}
-
-reload() {
- ebegin "Reloading ${SVCNAME}"
- /usr/sbin/haproxy -D -p "${PIDFILE}" -f "${CONFFILE}" -sf $(cat "${PIDFILE}")
- eend ${?}
-}