summaryrefslogtreecommitdiffstats
path: root/testing/haproxy
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2011-01-22 18:35:36 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-01-22 15:14:21 -0600
commitca7457196d326dadd5a2e537fac83a6f3cb88c7c (patch)
tree8a0d64428a2ddbe794f0c1585b553350ff6c2cc0 /testing/haproxy
parent890fdcbbe55ee0b070dac40f13ae2aa0ce77a0d7 (diff)
downloadaports-ca7457196d326dadd5a2e537fac83a6f3cb88c7c.tar.bz2
aports-ca7457196d326dadd5a2e537fac83a6f3cb88c7c.tar.xz
testing/haproxy: update to 1.4.10
update to 1.4.10
Diffstat (limited to 'testing/haproxy')
-rw-r--r--testing/haproxy/APKBUILD12
-rw-r--r--testing/haproxy/haproxy.initd6
2 files changed, 9 insertions, 9 deletions
diff --git a/testing/haproxy/APKBUILD b/testing/haproxy/APKBUILD
index 988569a65..9f8355de7 100644
--- a/testing/haproxy/APKBUILD
+++ b/testing/haproxy/APKBUILD
@@ -1,8 +1,8 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
+# Contributor: Jeff Bilyk <jbilyk@gmail.com>
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=haproxy
-pkgver=1.3.20
-pkgrel=2
+pkgver=1.4.10
+pkgrel=1
pkgdesc="A TCP/HTTP reverse proxy for high availability environments"
url="http://haproxy.1wt.eu"
arch="all"
@@ -11,7 +11,7 @@ depends=""
makedepends=""
install=
subpackages=""
-source="http://haproxy.1wt.eu/download/1.3/src/$pkgname-$pkgver.tar.gz
+source="http://haproxy.1wt.eu/download/1.4/src/$pkgname-$pkgver.tar.gz
haproxy.initd"
build() {
@@ -25,5 +25,5 @@ package() {
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
}
-md5sums="e37046e0cb2f407d92c41d7731d1dd10 haproxy-1.3.20.tar.gz
-7d26095c6f899b0ef00bedecaca58864 haproxy.initd"
+md5sums="c35a7b7820d6da6c34cfd952805b4e85 haproxy-1.4.10.tar.gz
+cce88addaac6ee8065633b94c404300d haproxy.initd"
diff --git a/testing/haproxy/haproxy.initd b/testing/haproxy/haproxy.initd
index 82a106759..68b7e0fef 100644
--- a/testing/haproxy/haproxy.initd
+++ b/testing/haproxy/haproxy.initd
@@ -13,7 +13,7 @@ checkconfig() {
eerror "${CONFFILE} does not exist!"
return 1
fi
- /usr/bin/haproxy -c -f "${CONFFILE}" >/dev/null
+ /usr/sbin/haproxy -c -f "${CONFFILE}" >/dev/null
}
depend() {
@@ -27,7 +27,7 @@ start() {
ebegin "Starting ${SVCNAME}"
start-stop-daemon --start --quiet \
- --exec /usr/bin/haproxy \
+ --exec /usr/sbin/haproxy \
-- -D -p "${PIDFILE}" -f "${CONFFILE}"
eend ${?}
}
@@ -40,6 +40,6 @@ stop() {
reload() {
ebegin "Reloading ${SVCNAME}"
- /usr/bin/haproxy -D -p "${PIDFILE}" -f "${CONFFILE}" -sf $(cat "${PIDFILE}")
+ /usr/sbin/haproxy -D -p "${PIDFILE}" -f "${CONFFILE}" -sf $(cat "${PIDFILE}")
eend ${?}
}