summaryrefslogtreecommitdiffstats
path: root/testing/hping3/APKBUILD
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-01-13 01:26:55 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-01-13 01:26:55 -0600
commitb046289271b7756bc57c889665a6d3f829307285 (patch)
treeb8d189671a1b2fa2f33f62631a7da2bc3dc49cdc /testing/hping3/APKBUILD
parent2b14708d36bd651a1819d9005e4d53f551862b89 (diff)
downloadaports-b046289271b7756bc57c889665a6d3f829307285.tar.bz2
aports-b046289271b7756bc57c889665a6d3f829307285.tar.xz
testing/hping3: bytesex.h fixes for x86_64, sh, ia64 and s390/s390x
Diffstat (limited to 'testing/hping3/APKBUILD')
-rw-r--r--testing/hping3/APKBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/testing/hping3/APKBUILD b/testing/hping3/APKBUILD
index 2359e388b..c58c0e4a0 100644
--- a/testing/hping3/APKBUILD
+++ b/testing/hping3/APKBUILD
@@ -2,31 +2,42 @@
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=hping3
pkgver=20051105
-pkgrel=1
+pkgrel=2
pkgdesc="A ping-like TCP/IP packet assembler/analyzer"
url="http://www.hping.org"
-arch="x86 x86_64"
+arch="all"
license="GPL"
depends=""
makedepends="libpcap-dev"
install=
subpackages="$pkgname-doc"
-source="http://www.hping.org/$pkgname-$pkgver.tar.gz"
+source="http://www.hping.org/$pkgname-$pkgver.tar.gz
+ hping3-bytesex.patch"
-build() {
- cd "$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
sed -i -e 's:net/bpf.h:pcap/bpf.h:' libpcap_stuff.c script.c || return 1
+ patch -p0 < "$srcdir"/hping3-bytesex.patch
+}
+
+build() {
+ cd "$_builddir"
+
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--no-tcl
+
make || return 1
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
+
install -m755 -D hping3 "$pkgdir"/usr/sbin/hping3
ln -s hping3 "$pkgdir"/usr/sbin/hping
ln -s hping3 "$pkgdir"/usr/sbin/hping2
@@ -34,4 +45,5 @@ package() {
install -m644 -D docs/hping3.8 "$pkgdir"/usr/share/man/man8/hping3.8
}
-md5sums="ca4ea4e34bcc2162aedf25df8b2d1747 hping3-20051105.tar.gz"
+md5sums="ca4ea4e34bcc2162aedf25df8b2d1747 hping3-20051105.tar.gz
+f2a6d31aa1694cfebe325929f832fd78 hping3-bytesex.patch"