summaryrefslogtreecommitdiffstats
path: root/testing/ices2
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-03-14 17:12:58 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-03-14 17:12:58 +0000
commitbd5df205483a38140e3d4073f4c83c5e3c1496ed (patch)
tree871b274efdbfb15d7b72ef4302ff027be7e0c065 /testing/ices2
parent539c1d369331cbc3fb3a46e3c93c39c4bae24c34 (diff)
downloadaports-bd5df205483a38140e3d4073f4c83c5e3c1496ed.tar.bz2
aports-bd5df205483a38140e3d4073f4c83c5e3c1496ed.tar.xz
testing/ices: new aport : source client for broadcasting in Ogg Vorbis format to an icecast2 server
Diffstat (limited to 'testing/ices2')
-rw-r--r--testing/ices2/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/ices2/APKBUILD b/testing/ices2/APKBUILD
new file mode 100644
index 000000000..d37eb8196
--- /dev/null
+++ b/testing/ices2/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer:
+pkgname=ices2
+_pkgname=ices
+pkgver=2.0.1
+pkgrel=0
+pkgdesc="source client for broadcasting in Ogg Vorbis format to an icecast2 server."
+url="http://icecast.org/ices.php"
+arch="all"
+license="GPL"
+depends=
+depends_dev="libogg-dev libxml2-dev libvorbis-dev libshout-dev"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://downloads.us.xiph.org/releases/ices/$_pkgname-$pkgver.tar.gz"
+
+_builddir=$srcdir/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="0d95ac34d59fed337028d5e7771076d8 ices-2.0.1.tar.gz"