summaryrefslogtreecommitdiffstats
path: root/testing/nebula
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-06-03 14:16:10 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2014-06-03 14:18:15 +0200
commitdfbaeba59fa9e3a19bc912f7d30c0e05c12033f1 (patch)
tree1c150484ea000e7c877b9dc05e1b0c70d0a9cd2f /testing/nebula
parent9f9b6f52f31fb032b8ba02161e920e81dbc53271 (diff)
downloadaports-dfbaeba59fa9e3a19bc912f7d30c0e05c12033f1.tar.bz2
aports-dfbaeba59fa9e3a19bc912f7d30c0e05c12033f1.tar.xz
testing/nebula: move back to testing and fix musl build
Diffstat (limited to 'testing/nebula')
-rw-r--r--testing/nebula/APKBUILD57
-rw-r--r--testing/nebula/musl-fixes.patch32
2 files changed, 89 insertions, 0 deletions
diff --git a/testing/nebula/APKBUILD b/testing/nebula/APKBUILD
new file mode 100644
index 000000000..9e66f7dfa
--- /dev/null
+++ b/testing/nebula/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=nebula
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="An Intrusion Signature Generator"
+url="http://nebula.carnivore.it/"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="zlib-dev"
+install=""
+subpackages="$pkgname-client"
+source="http://downloads.sourceforge.net/nebula/$pkgname-$pkgver.tar.gz
+ musl-fixes.patch"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make AM_CFLAGS=-D_GNU_SOURCE || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+client() {
+ #cd "$_builddir"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/"$pkgname"client "$subpkgdir"/usr/bin/
+}
+
+md5sums="06eabd66634e7969203465fb94900f18 nebula-0.2.3.tar.gz
+393c6ba03578214aa720cd8a703d8b1b musl-fixes.patch"
+sha256sums="6d90fe1c5c1d81045134485e8ee4e888e9fce5d4323a2b6b321bf8a9765fc856 nebula-0.2.3.tar.gz
+e35212e0b65711fd9ead733e15fe76c79a15de7ac7c417a4c26df400df6f590b musl-fixes.patch"
+sha512sums="9202be7ca3c78e7dadf559180a3a9a331ed0ddd4b04aa16ac0c65856f513e600e4e04b7908d4be412360c3fc7e91a286723be1151c74333f0111a4307e323023 nebula-0.2.3.tar.gz
+790c3682e3a32da44e83bcfc44c1483b866d526efdfee6522a42878a9ac3aab65341515c9a080e22e44f5e9daff3b4c55c3e53da6ee68e6580df74850e3b44dd musl-fixes.patch"
diff --git a/testing/nebula/musl-fixes.patch b/testing/nebula/musl-fixes.patch
new file mode 100644
index 000000000..a23d8a1a0
--- /dev/null
+++ b/testing/nebula/musl-fixes.patch
@@ -0,0 +1,32 @@
+--- nebula-0.2.3/src/hash.h
++++ nebula-0.2.3/src/hash.h
+@@ -24,7 +24,7 @@
+ #if HAVE_CONFIG_H
+ # include <config.h>
+ #endif
+-
++#include "sys/types.h"
+
+ struct cluster;
+
+--- nebula-0.2.3/src/spamsum.h
++++ nebula-0.2.3/src/spamsum.h
+@@ -24,7 +24,7 @@
+ #if HAVE_CONFIG_H
+ # include <config.h>
+ #endif
+-
++#include "sys/types.h"
+
+ char *spamsum(const u_char *in, size_t length, uint32_t bsize);
+ uint32_t spamsum_match(const char *str1, const char *str2);
+--- nebula-0.2.3/src/trie.h
++++ nebula-0.2.3/src/trie.h
+@@ -24,6 +24,7 @@
+ #if HAVE_CONFIG_H
+ # include <config.h>
+ #endif
++#include "sys/types.h"
+
+ struct trie_node;
+ typedef struct trie_node *trie;