summaryrefslogtreecommitdiffstats
path: root/testing/pcapy
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-09 14:56:23 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:16 -0600
commit4bb6ca58b6f2a1358527867e93fe20b5feb807cc (patch)
treee62c9269b047fc228d82a636b784ec863c9b22c5 /testing/pcapy
parentd4f831a6ec9c95577be710ccaafeff4a6997c2fd (diff)
downloadaports-4bb6ca58b6f2a1358527867e93fe20b5feb807cc.tar.bz2
aports-4bb6ca58b6f2a1358527867e93fe20b5feb807cc.tar.xz
Initial APKBUILD for pcapy
Package description: Pcapy is a Python extension module that interfaces with the libpcap packet capture library. Pcapy enables python scripts to capture packets on the network. Pcapy is highly effective when used in conjunction with a packet-handling package such as Impacket, which is a collection of Python classes for constructing and dissecting network packets.
Diffstat (limited to 'testing/pcapy')
-rw-r--r--testing/pcapy/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/pcapy/APKBUILD b/testing/pcapy/APKBUILD
new file mode 100644
index 000000000..ac211824e
--- /dev/null
+++ b/testing/pcapy/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=pcapy
+pkgver=0.10.5
+pkgrel=0
+pkgdesc="Module to interfaces with the libpcap packet capture library"
+url="http://oss.coresecurity.com/projects/pcapy.html"
+arch="all"
+license="ASL"
+depends=""
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://oss.coresecurity.com/repo/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="1dcff6af494f3d6763f457aa86aa0853 pcapy-0.10.5.tar.gz"