summaryrefslogtreecommitdiffstats
path: root/testing/perl-io-async-ssl
diff options
context:
space:
mode:
authorKiyoshi Aman <aphrael@alpinelinux.org>2011-12-01 08:38:56 -0500
committerKiyoshi Aman <aphrael@alpinelinux.org>2011-12-04 22:09:38 -0500
commit4ba3381628631e45481225acf3f11dd31f37bf2e (patch)
treeb627c01e649d35f6a5589888c556f25c2048d04a /testing/perl-io-async-ssl
parent8248f5844b47ffe2f6949983963f0007aeab68c6 (diff)
downloadaports-4ba3381628631e45481225acf3f11dd31f37bf2e.tar.bz2
aports-4ba3381628631e45481225acf3f11dd31f37bf2e.tar.xz
testing/perl-io-async-ssl: new APKBUILD
Diffstat (limited to 'testing/perl-io-async-ssl')
-rw-r--r--testing/perl-io-async-ssl/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/perl-io-async-ssl/APKBUILD b/testing/perl-io-async-ssl/APKBUILD
new file mode 100644
index 000000000..933343d54
--- /dev/null
+++ b/testing/perl-io-async-ssl/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=perl-io-async-ssl
+_pkgreal=IO-Async-SSL
+pkgver=0.06
+pkgrel=0
+pkgdesc="Use SSL/TLS with L<IO::Async>"
+url="http://search.cpan.org/dist/IO-Async-SSL/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-io-socket-ssl perl-io-async"
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ perl Build.PL installdirs=vendor || return 1
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install destdir="$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="d357dc71b0bbc0f43ba8fd55f869ae54 IO-Async-SSL-0.06.tar.gz"