summaryrefslogtreecommitdiffstats
path: root/testing/perl-test-harness
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-10-27 17:28:24 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-10-27 17:28:24 +0000
commit26b202c8fcdf4391a1bb5a79cca0693b78a27e86 (patch)
treecb45feaa668f674ce674ff2b2944e072ff21c8aa /testing/perl-test-harness
parente246c3f8ac790cf06cf45a5742ec55807c2b7586 (diff)
downloadaports-26b202c8fcdf4391a1bb5a79cca0693b78a27e86.tar.bz2
aports-26b202c8fcdf4391a1bb5a79cca0693b78a27e86.tar.xz
testing/perl-test-harness: new aport
Diffstat (limited to 'testing/perl-test-harness')
-rw-r--r--testing/perl-test-harness/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/perl-test-harness/APKBUILD b/testing/perl-test-harness/APKBUILD
new file mode 100644
index 000000000..8c82a585c
--- /dev/null
+++ b/testing/perl-test-harness/APKBUILD
@@ -0,0 +1,39 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-test-harness
+_pkgreal=Test-Harness
+pkgver=3.25
+pkgrel=0
+pkgdesc="Run Perl standard test scripts with statistics"
+url="http://search.cpan.org/dist/Test-Harness/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/O/OV/OVID/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="69a8a019eeb952fe97e3ac0767c726da Test-Harness-3.25.tar.gz"