summaryrefslogtreecommitdiffstats
path: root/testing/py-flask-gzip
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-14 08:35:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:26 +0000
commitd8abb9ad584efee49b2e99904b4596c4bd886884 (patch)
tree913519a26c017992a93e0930566bd5dc3e3f2396 /testing/py-flask-gzip
parent944e72bb4f49c4618f309fcb9896356e585d9f44 (diff)
downloadaports-d8abb9ad584efee49b2e99904b4596c4bd886884.tar.bz2
aports-d8abb9ad584efee49b2e99904b4596c4bd886884.tar.xz
testing/py-flask-gzip: new aport
Flask gzip support https://pypi.python.org/pypi/Flask-gzip
Diffstat (limited to 'testing/py-flask-gzip')
-rw-r--r--testing/py-flask-gzip/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flask-gzip/APKBUILD b/testing/py-flask-gzip/APKBUILD
new file mode 100644
index 000000000..072ce4788
--- /dev/null
+++ b/testing/py-flask-gzip/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-gzip
+_pkgname=Flask-gzip
+pkgver=0.1
+pkgrel=0
+pkgdesc="Flask gzip support"
+url="https://pypi.python.org/pypi/Flask-gzip"
+arch="noarch"
+license="BSD"
+depends="python py-flask"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="019281380d1fd4c4c90b5e6d8fc02549 Flask-gzip-0.1.tar.gz"
+sha256sums="8bcd65be14939d3ab6338a7b3bee02da047d64b71e2350429073a267369aaf83 Flask-gzip-0.1.tar.gz"
+sha512sums="908ed55b1e75396ea50bcbf5a4466ada8783963611ee549fd9938a87e7028b560068fd7bdee844f7c4412c3c244ae027ea98e2fd9bd7d034aefe253561998cc2 Flask-gzip-0.1.tar.gz"