summaryrefslogtreecommitdiffstats
path: root/testing/py-logbook
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-04-17 21:45:25 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2014-04-17 21:45:25 +0200
commitec536c56553587c62a075240a02957ac04b60216 (patch)
treef89246a31449e8eb8793955cd45e0b42bedfb6c0 /testing/py-logbook
parentaab955ebdd620a4977f91e80cd51bbd119841f07 (diff)
downloadaports-ec536c56553587c62a075240a02957ac04b60216.tar.bz2
aports-ec536c56553587c62a075240a02957ac04b60216.tar.xz
testing/py-logbook: new aport
A logging replacement for Python https://pypi.python.org/pypi/Logbook
Diffstat (limited to 'testing/py-logbook')
-rw-r--r--testing/py-logbook/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/py-logbook/APKBUILD b/testing/py-logbook/APKBUILD
new file mode 100644
index 000000000..d1ebb5cf3
--- /dev/null
+++ b/testing/py-logbook/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-logbook
+pkgver=0.6.0
+pkgrel=0
+pkgdesc="A logging replacement for Python"
+url="https://pypi.python.org/pypi/Logbook"
+arch="noarch"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev python py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/L/Logbook/Logbook-$pkgver.tar.gz"
+
+_builddir="$srcdir"/Logbook-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="2c77da3adeafd191bb8071cc5ad447bf Logbook-0.6.0.tar.gz"
+sha256sums="e6391281a8a4c34b0758e65d72f3d5d990e4cfdb326336fc0a526bcacb8f10d6 Logbook-0.6.0.tar.gz"
+sha512sums="41a939558976f51f1e82d2f1cf09a053eebd32ed45d76eb198d465bffe26011101e9a183dac03df34493e3ac81cd1218f8bb623dc97dd54e3c0cfc5d91fffdaa Logbook-0.6.0.tar.gz"