summaryrefslogtreecommitdiffstats
path: root/testing/py-msgpack/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-04 19:12:30 +0000
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-09-08 14:29:24 +0200
commit3fd152b0edd030ac203bd787aedb2752cd56ea30 (patch)
tree4904001b91680fe7247dd3854ca75962f382e269 /testing/py-msgpack/APKBUILD
parent28fbe7f4bd918e1ced0abe858a5bad2aba08355e (diff)
downloadaports-3fd152b0edd030ac203bd787aedb2752cd56ea30.tar.bz2
aports-3fd152b0edd030ac203bd787aedb2752cd56ea30.tar.xz
testing/py-msgpack: specify license
Diffstat (limited to 'testing/py-msgpack/APKBUILD')
-rw-r--r--testing/py-msgpack/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/py-msgpack/APKBUILD b/testing/py-msgpack/APKBUILD
index fa6e604af..1878ce495 100644
--- a/testing/py-msgpack/APKBUILD
+++ b/testing/py-msgpack/APKBUILD
@@ -7,20 +7,21 @@ pkgrel=0
pkgdesc="Python module for MessagePack serialization/deserialization library"
url="http://pypi.python.org/pypi/msgpack-python/"
arch="all"
-license="APACHE"
+license="ASL 2.0"
depends=""
makedepends="python-dev py-setuptools"
subpackages=""
source="http://pypi.python.org/packages/source/m/$_realname/$_realname-$pkgver.tar.gz"
+
_builddir="$srcdir"/$_realname-$pkgver
build () {
cd "$_builddir"
- python setup.py build
+ python setup.py build || return 1
}
package() {
cd "$_builddir"
- python setup.py install --root="$pkgdir"
+ python setup.py install --root="$pkgdir" || return 1
}
md5sums="10dec96c90992b0f6e38bdf0cc5a8e79 msgpack-python-0.3.0.tar.gz"