summaryrefslogtreecommitdiffstats
path: root/testing/py-oauth2
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-06 21:11:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:15 +0000
commitf825fe5642d8083bf10278de2bbd2cb432515045 (patch)
tree03253d1866ef8d842ac108de0a09342f34fa5626 /testing/py-oauth2
parentb2e122ca6dee922008a54c71135e157670c405d5 (diff)
downloadaports-f825fe5642d8083bf10278de2bbd2cb432515045.tar.bz2
aports-f825fe5642d8083bf10278de2bbd2cb432515045.tar.xz
testing/py-oauth2: new aport
A Python library for OAuth https://github.com/simplegeo/python-oauth2
Diffstat (limited to 'testing/py-oauth2')
-rw-r--r--testing/py-oauth2/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-oauth2/APKBUILD b/testing/py-oauth2/APKBUILD
new file mode 100644
index 000000000..676cc4f70
--- /dev/null
+++ b/testing/py-oauth2/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-oauth2
+_pkgname=oauth2
+pkgver=1.5.211
+pkgrel=0
+pkgdesc="A Python library for OAuth"
+url="https://github.com/simplegeo/python-oauth2"
+arch="noarch"
+license="MIT"
+depends="python py-httplib2"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="987ad7365a70e2286bd1cebb344debbc oauth2-1.5.211.tar.gz"
+sha256sums="82a38f674da1fa496c0fc4df714cbb058540bed72a30c50a2e344b0d984c4d21 oauth2-1.5.211.tar.gz"
+sha512sums="3f5606702d4e305c191c924cab01ee3fc7e170a26460c1d49031e3d9a296b3502d5e18edb1ec0e291abd61797cb47b7b2b8929eff33eb8bc9fd73434b3ab028a oauth2-1.5.211.tar.gz"