summaryrefslogtreecommitdiffstats
path: root/testing/py-pep8
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-05 20:28:50 +0000
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-09-08 14:35:46 +0200
commitd4e193c8ab96231b13ae33735f82a27c4830c3ac (patch)
treed80ed2f874e186e23c830f09f50b0ca448d6fe66 /testing/py-pep8
parent3e84b151947bd52d047cb35ab0956e91c7cdd22d (diff)
downloadaports-d4e193c8ab96231b13ae33735f82a27c4830c3ac.tar.bz2
aports-d4e193c8ab96231b13ae33735f82a27c4830c3ac.tar.xz
testing/py-pep8: new aport
A Python style guide checker https://pypi.python.org/pypi/pep8/
Diffstat (limited to 'testing/py-pep8')
-rw-r--r--testing/py-pep8/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-pep8/APKBUILD b/testing/py-pep8/APKBUILD
new file mode 100644
index 000000000..7f101fec1
--- /dev/null
+++ b/testing/py-pep8/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pep8
+_pkgname=pep8
+pkgver=1.4.6
+pkgrel=0
+pkgdesc="A Python style guide checker"
+url="https://pypi.python.org/pypi/pep8/"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="a03bb494859e87b42601b61b1b043a0c pep8-1.4.6.tar.gz"
+sha256sums="603a46e5c358ce20ac4807a0eeafac7505d1125a4c1bd8378757ada06f61bed8 pep8-1.4.6.tar.gz"
+sha512sums="3752bef4cf8064b6f965bde0ccbe5e546c1e53496814c49d959d2148d9707848d0ebb79c9394f4b1a43575bab61db8ea58ac3bffb24d6f8d41abddffaf483f55 pep8-1.4.6.tar.gz"