summaryrefslogtreecommitdiffstats
path: root/testing/py-pysqlite
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2013-12-26 20:15:19 +0100
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2013-12-26 20:15:19 +0100
commitfd43c6043a3e7405be41e6763fd388d324d33088 (patch)
tree46bf4f8cc3abb026b360bade98dfd3856eb9aac8 /testing/py-pysqlite
parent0779d2695e741741eb019eb303286bc03bd3b2f7 (diff)
downloadaports-fd43c6043a3e7405be41e6763fd388d324d33088.tar.bz2
aports-fd43c6043a3e7405be41e6763fd388d324d33088.tar.xz
testing/py-pysqlite: new aport
Diffstat (limited to 'testing/py-pysqlite')
-rw-r--r--testing/py-pysqlite/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py-pysqlite/APKBUILD b/testing/py-pysqlite/APKBUILD
new file mode 100644
index 000000000..0c737b5a2
--- /dev/null
+++ b/testing/py-pysqlite/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer:
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=py-pysqlite
+_pkgname=pysqlite
+pkgver=2.6.3
+pkgrel=0
+pkgdesc='Python DB-API 2.0 interface for the SQLite'
+url='http://code.google.com/p/pysqlite/'
+arch='all'
+license='MIT'
+makedepends="python-dev py-setuptools sqlite-dev"
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="7ff1cedee74646b50117acff87aa1cfa pysqlite-2.6.3.tar.gz"
+sha256sums="fe9c35216bf56c858b34c4b4c8be7e34566ddef29670e5a5b43f9cb8ecfbb28d pysqlite-2.6.3.tar.gz"
+sha512sums="1b8ce3b5300c1d8568ef59d4967ccd06c5e80ea45c2ffdb9d6744712f12b0b2649ade646f926562bf59b660d6d56bfc478780f22577c96cb758f1de7259570a2 pysqlite-2.6.3.tar.gz"