summaryrefslogtreecommitdiffstats
path: root/testing/py-qt
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-06-20 12:00:47 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-06-20 12:02:01 +0000
commit9c6e16bb228787c35137e4a5576a5085a9788a10 (patch)
treefee729147f5d9c0ee9189dfad821042b129668cd /testing/py-qt
parent6a3353563b226569a73920d63a1ef672043b21b5 (diff)
downloadaports-9c6e16bb228787c35137e4a5576a5085a9788a10.tar.bz2
aports-9c6e16bb228787c35137e4a5576a5085a9788a10.tar.xz
testing/chmlib podofo py-dateutils py-importlib py-pycountry py-qt py-sip : new aports
Diffstat (limited to 'testing/py-qt')
-rw-r--r--testing/py-qt/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py-qt/APKBUILD b/testing/py-qt/APKBUILD
new file mode 100644
index 000000000..1d2295178
--- /dev/null
+++ b/testing/py-qt/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=py-qt
+_pkgname=PyQt
+pkgver=4.8.4
+pkgrel=0
+pkgdesc="A set of Python bindings for the Qt toolkit"
+url="http://riverbankcomputing.co.uk/software/pyqt/intro"
+arch="all"
+license="GPL"
+depends=
+depends_dev="python-dev py-dbus-dev phonon-dev qt-dev py-sip-dev libx11-dev"
+makedepends="$depends_dev"
+subpackages=""
+install=
+source="http://riverbankcomputing.co.uk/static/Downloads/${_pkgname}4/${_pkgname}-x11-gpl-$pkgver.tar.gz"
+build() {
+ cd "${srcdir}/PyQt-x11-gpl-${pkgver}"
+ python configure.py \
+ --confirm-license \
+ -v /usr/share/sip \
+ --qsci-api
+ # Thanks Gerardo for the rpath fix
+ find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
+ make
+}
+package(){
+ cd "${srcdir}/PyQt-x11-gpl-${pkgver}"
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+}
+
+md5sums="97c5dc1042feb5b3fe20baabad055af1 PyQt-x11-gpl-4.8.4.tar.gz"