summaryrefslogtreecommitdiffstats
path: root/testing/rats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-15 14:47:33 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:16 -0600
commit127b6bb76e04cdcb753420e91966c274d5884f31 (patch)
tree0e7eed9e2768db19287e18e6682582d3a4d64f5e /testing/rats
parent2463fcc7d56cf976f28c97b286a916447bf859e0 (diff)
downloadaports-127b6bb76e04cdcb753420e91966c274d5884f31.tar.bz2
aports-127b6bb76e04cdcb753420e91966c274d5884f31.tar.xz
Initial APKBUILD for rats
Package description: This is RATS, a rough auditing tool for security, developed by Secure Software Inc. It is a tool for scanning C, C++, Perl, PHP, Python and Ruby source code and flagging common security related programming errors such as buffer overflows and TOCTOU (Time Of Check, Time Of Use) race conditions. As its name implies, the tool performs only a rough analysis of source code. It will not find every error and will also find things that are not errors. Manual inspection of your code is still necessary, but greatly aided with this tool.
Diffstat (limited to 'testing/rats')
-rw-r--r--testing/rats/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/rats/APKBUILD b/testing/rats/APKBUILD
new file mode 100644
index 000000000..cfea0595c
--- /dev/null
+++ b/testing/rats/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=rats
+pkgver=2.3
+pkgrel=0
+pkgdesc="A tool to find security related programming errors"
+url="https://www.fortify.com/ssa-elements/threat-intelligence/rats.html"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="expat-dev wget flex"
+install=""
+subpackages="$pkgname-doc"
+source="https://www.fortify.com/downloads2/public/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --datadir=/usr/share/ \
+ --mandir=/usr/share/man
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ ##make DESTDIR="$pkgdir" install || return 1
+ install -Dpm 0755 "$pkgname" "$pkgdir"/usr/bin/$pkgname || return 1
+ mkdir -p "$pkgdir"/usr/share/$pkgname || return 1
+ install -Dm 0644 *.xml "$pkgdir"/usr/share/$pkgname/ || return 1
+}
+
+doc() {
+ # The man page is not picked-up automatically
+ mkdir -p "$subpkgdir"/usr/share/man/man1 || return 1
+ mv "$_builddir"/*.1 "$subpkgdir"/usr/share/man/man1/ || return 1
+}
+
+md5sums="339ebe60fc61789808a457f6f967d226 rats-2.3.tar.gz"