summaryrefslogtreecommitdiffstats
path: root/testing/rutorrent
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-06-02 06:15:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-06-02 06:22:02 +0000
commit71132bd1561a8d0fb1f92877033f67860d46d180 (patch)
tree79b17a89b559b567280d7042eaa882f6cc5ae14a /testing/rutorrent
parent44057af830e8edd2b84b2c49a4d7f373df7949b5 (diff)
downloadaports-71132bd1561a8d0fb1f92877033f67860d46d180.tar.bz2
aports-71132bd1561a8d0fb1f92877033f67860d46d180.tar.xz
testing/rutorrent: upgrade to 3.6
we depend on tar sine the tarball comtains files with readonly permissions. busybox tar gets problems with writing to the dirs with those permissions.
Diffstat (limited to 'testing/rutorrent')
-rw-r--r--testing/rutorrent/APKBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/testing/rutorrent/APKBUILD b/testing/rutorrent/APKBUILD
index 7310d60e9..8f69bc2af 100644
--- a/testing/rutorrent/APKBUILD
+++ b/testing/rutorrent/APKBUILD
@@ -1,23 +1,29 @@
# Contributor: Francesco Colista <francesco.colista@gmail.com>
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=rutorrent
-pkgver=3.5
-pkgrel=1
+pkgver=3.6
+pkgrel=0
pkgdesc="Yet another web front-end for rTorrent"
url="http://code.google.com/p/rutorrent/"
arch="noarch"
license="GPL"
depends="php curl"
depends_dev=""
-makedepends=""
+
+# we need to user gnu tar since the permissions on files in tar archive are
+# bad
+makedepends="tar"
+
pkggroups="rutorrent"
install="$pkgname.pre-install $pkgname.post-install"
subpackages=""
-source="http://rutorrent.googlecode.com/files/$pkgname-$pkgver.tar.gz"
+source="http://dl.bintray.com/novik65/generic/rutorrent-$pkgver.tar.gz"
_builddir="$srcdir"/$pkgname
+
build() {
cd "$_builddir"
+ chmod -R u+w "$_builddir"
}
package() {
@@ -31,4 +37,6 @@ package() {
chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/users
}
-md5sums="210cbabe0ead88c865c654bab2109e92 rutorrent-3.5.tar.gz"
+md5sums="e5a908b9473be73007b614f4a72fc1d3 rutorrent-3.6.tar.gz"
+sha256sums="cd2fb3c4e2799f232bf0844b54ce2065d34a927a15b7ae14746714ce79d829f5 rutorrent-3.6.tar.gz"
+sha512sums="a3686c77ced2a76f0656bee776f6536d8967cebb130a87987b7be40b4183fb3cb9598ded230831a54e213a3f87a2a2a8829fb6a329bd9fe8a3f520d5f34dcd3b rutorrent-3.6.tar.gz"