summaryrefslogtreecommitdiffstats
path: root/testing/sipcrack
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-05-19 10:40:42 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-20 16:57:44 +0000
commit714af606f0b2c063827a03670a65584ed77612c4 (patch)
tree7158c929051e8686adedec4198460c94d48b6164 /testing/sipcrack
parent2bd675a6706a27bc8098dfd924e34e7688508934 (diff)
downloadaports-714af606f0b2c063827a03670a65584ed77612c4.tar.bz2
aports-714af606f0b2c063827a03670a65584ed77612c4.tar.xz
testing/sipcrack: new aport
The tools contained in this package offer support for pcap files, wordlists and many more to extract all needed information and bruteforce the passwords for the sniffed accounts. http://packages.debian.org/squeeze/sipcrack
Diffstat (limited to 'testing/sipcrack')
-rw-r--r--testing/sipcrack/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/sipcrack/APKBUILD b/testing/sipcrack/APKBUILD
new file mode 100644
index 000000000..b8e7e5efb
--- /dev/null
+++ b/testing/sipcrack/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=sipcrack
+pkgver=0.2
+pkgrel=0
+pkgdesc="A SIP protocol login cracker"
+url="http://packages.debian.org/lenny/sipcrack"
+arch="all"
+license="Custom"
+depends=""
+depends_dev=""
+makedepends="libpcap-dev openssl-dev"
+install=""
+subpackages=""
+source="http://ftp.de.debian.org/debian/pool/main/s/$pkgname/"$pkgname"_"$pkgver".orig.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ for file in sipcrack sipdump; do
+ install -Dm 0755 $file "$pkgdir"/usr/bin/$file || return 1
+ done
+}
+
+md5sums="b9096c8d537fc231c7d74b759831a4c7 sipcrack_0.2.orig.tar.gz"